Results 1 to 9 of 9

Thread: Eth0 Issues

  1. #1
    Just burned his ISO sirwolfgang's Avatar
    Join Date
    Jan 2010

    Question Eth0 Issues

    I just setup BT4 on a USB and its working fine and all, But i am having issues connecting to my network/internet.

    <As Root>
    #this runs thru alot sending dhcp request and discovers all on the eth0, but can't reslove anything.

    My router is acting correctly which leaves this issues to BT & hardware.. I cant cut and paste since its not working, but ill see what i can do if you need anything, so any thoughts??

  2. #2
    Developer balding_parrot's Avatar
    Join Date
    May 2007

    Default Re: Eth0 Issues

    When you run dhclient try specifying the interface

    As in

    dhclient eth0

    If that doesn't work for you, come back with more info about your hardware etc

  3. #3
    Join Date
    Jan 2010
    The new forums

    Default Re: Eth0 Issues

    So you are getting an IP, but you are not able to browse the internet?

    You could see what's in your resolv.conf
    cat /etc/resolv.conf
    I would try pinging Google by IP and then by name. If you can ping by IP but not the name, then just add a DNS name server to your config.
    echo "nameserver" >> /etc/resolv.conf
    If you can't do either, then it's another issue.
    Last edited by Lincoln; 01-15-2010 at 03:47 AM.

  4. #4
    Just burned his ISO
    Join Date
    Jan 2010
    A place called home

    Default Re: Eth0 Issues

    your issue may be that your running off of USB. For me, when using a USB or LiveCD, the eth0 driver won't work, but when using BT4 from my hard drive, it works fine. Its not that hard putting BT4 on your hard drive, I would recommend you do, if its possible.

  5. #5
    Just burned his ISO sirwolfgang's Avatar
    Join Date
    Jan 2010

    Default Re: Eth0 Issues

    [balding_parrot] Ya, that was one of the first things i tried, did it again here is my output
    Listening on LPF/eth0/00:50:8d:9d:7f:ca
    Sending on   LPF/eth0/00:50:8d:9d:7f:ca
    Sending on   Socket/fallback
    DHCPREQUEST of on eth0 to port 67
    DHCPREQUEST of on eth0 to port 67
    DHCPDISCOVER on eth0 to port 67 interval 6
    DHCPDISCOVER on eth0 to port 67 interval 12
    DHCPDISCOVER on eth0 to port 67 interval 9
    DHCPDISCOVER on eth0 to port 67 interval 8
    DHCPDISCOVER on eth0 to port 67 interval 11
    DHCPDISCOVER on eth0 to port 67 interval 8
    DHCPDISCOVER on eth0 to port 67 interval 7
    No DHCPOFFERS received.
    Trying recorded lease
    PING ( 56(84) bytes of data.
    --- ping statistics ---
    1 packets transmitted, 0 received, +1 errors, 100% packet loss, time 0ms
    No working leases in persistent database - sleeping.
    It is showing correctly to how my network is setup, but when i try to open my router from a firefoxr it is unable to connect,
    root@bt:~# cat /etc/resolv.conf
    As far as my hardware goes:
    Eth0: NVIDIA nForce Networking Controller

    ..That's the only thing I can think relevant to the issue..

    If that is true, it would be related to a difference in settings then hardware issues, upon boot the PC things the USB is the HDD so there would be no difference there. I have not put it on the my HDD and do not plan on it unless necessary to test the difference to do so would defeat the point of having it on a USB :P

  6. #6
    Just burned his ISO
    Join Date
    Jan 2010

    Default Re: Eth0 Issues

    well, there are many answers to your problem.


    _ Click on Start> Services> Network> Start Network
    _ Then click on Start> Internet> Wcid Network Manager
    in Wcid Network Manager click on Preferences
    a box will apear and in General Settings will you see Wired Interface: and at it's right a something written ( or empty). Just typt etc0 and click ok


    The problem could be that you've got a router that doesn't support ipv6.
    p.s. Backtrack 4 comes in ipv6 by default.

    so how to fix the problem?

    - open firefox
    - on the url type or
    - you'll enter to the routers settings.
    - now if possible, change the settings ( in advanced settings if aviable) from ipv4 to ipv6

    this should do the work

    for any more questions, just ask


  7. #7
    Just burned his ISO sirwolfgang's Avatar
    Join Date
    Jan 2010


    I went through all of that, I can't even connect to my router setting through firefox, I have checked all the hardware, and everything was fine in the pre-release of BT4.. So At this point I am think it has to do with a driver/interface issue.. its like the matrix something has changed

    I do not seem to be able to get eth0 to work at all, so until it randomly starts working due to an update when i am on my home PC i will just use my wireless

    Thanks for all your help, Let me know if you get anymore ideas
    Last edited by lupin; 01-18-2010 at 02:52 AM. Reason: Merging...

  8. #8
    Just burned his ISO
    Join Date
    Jan 2010

    Lightbulb Re: Eth0 Issues

    try this

    /etc/init.d/networking start

    this should work.

    Good luck!

  9. #9
    Just burned his ISO
    Join Date
    Jun 2010

    Default Re: Eth0 Issues

    I have exactly the same issue
    Normaly i use backtrack in vmware.
    But i wanted to play with cuda so i installed bt4 on my harddrive.
    i know i've got networking set up properly. wlan is working fine.
    eth0 and eth1 are not connecting propperly.
    No DHCP configuration
    No static ip functionality.

    So i thought driver issues I also have the nvidia network chipset (marvell)
    so i installed the drivers from the marvell site
    Driver version: (Apr-27-2010)
    Kernel version

    still no connectivity.

    Please don't reply with
    please try /etc/init.d/networking start
    or use wicd
    or configure the ip adress manualy
    or check your DNS.

    Its all fine.
    wlan works fine.

    just stuck with the nvidia / marvell ethernet functionallity

    (excuse my english )

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts