Quote Originally Posted by janus View Post
Hello everyone,

great tutorial, thanks for sharing.

I followed all the instructions and everything works fine until I start nessusclient and I get the following error message:

/opt/nessus/bin/NessusClient: error while loading shared libraries: libQtXml.so.4: cannot open shared object file: No such file or directory

I've searched around and can't find an answer to the problem. I updated the QT package again through gslapt but it seems that somehow the libQtXml.so.4: is nowhere to be found.
Any ideas?

(I'm using Nessus-3.2.1-fc9.i386.tgz and NessusClient- packages from nessus website and I have Slackware 12.0 and have updated everything through FastTrack).
Well nothing like DIY tinkering. I compiled and installed the qt4 package manually (apparently that's what the new nessus client uses and it is not in BT3 or available through Gslapt) and updated the ld.conf to point there.

Now when i run nessusclient i get a different error so some progress but still not there yet:

/opt/nessus/bin/NessusClient: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.9' not found (required by /opt/nessus/bin/NessusClient)