I was a happy browser of your forums and generally have found very comprehensive and professional information on any issue that I had with BackTrack 2 up until now and so I have decided to register because I have encountered a problem that is pretty specific to my setup. And I have googled a LOT and have not found a single thread that was related to my problem.
Specifically I have a GPS device Haicom Hi-204 III which I have problems with being recognized by kismet. I am using BackTrack 2. First of all I hook up my GPS device, get a

going... and see that my usb converter device is recognized
next I give it a

cat /dev/tts/USB0
I see data being read so then I start gpsd with

gpsd /dev/tts/USB0
,since my device has a USB converter. Then I give it another test with Telnet:

telnet localhost 2947
, then I type "r" and again, I see that the device sends information.

At this point I should be finished configuring/checking the GPS device so I fire up kismet with the autoconfig utility. And I have checked that autoconfig has configured the necessary parameters namely the gps=true and port 2947 on localhost correctly.

I also made sure that my device has locked my position before starting kismet (the device was blinking), however the bar where the GPS coordinates are displayed in kismet is present, but it shows nothing. That means EVERY value (Lon,Lat..etc) is 000.0.
I have tried GPSdrive and it worked.
I have also tried Xgps and it kinda worked...By this I mean values were flickering between N/A and some wrong coordinates. Also I didn't see any map or visualization on the xgps program, the area just stayed blank.
I have tested the device under windows (Autoroute and it has also worked perfectly).

As mentioned before I am through some extensive research and the closest someone got to my problem is described in this thread:
go to google and type in "kismet GPS issues" ... the first entry should be it
however I don't know if our problems have the same origin, as said before thats the closest I got.

I would really appreciate any help you guys can give me. I have come a long way and cut through the thick lumbers of the "Linux-forest" of commands and errors and I do not want it to end here... I am way too close for that

Thank you