It's a long story but it goes something like this. I got BT3 installed on my HDD and there's no sound. A bunch of searching said to update the kernel and I worked on that. I never compiled a kernel before, but I didn't think it would be too hard. Looking at numerous guides it seemed pretty simple. There was only 1 small issue. I couldn't seem to find the previous config of BT on the HDD. There's no /usr/src/linux directory here. So I downloaded the kernel sources from BT Wiki and used the config from there. I proceeded as normal and edited Lilo to use the new kernel ( and the old as a backup.

Problem: Kernel panic because could not mount. Detected partitions are recognized as HDA1 and HDA2, but the BT Live CD and HDD see it as SDA. Searching around suggests that I'm using the old device support (Legacy?) and need to enable Libata so it can change from hda > sda.

I tried enabling and disabling Legacy in the kernel, and I can't find Libata in it. Is the config just elsewhere on BT Live CD/HDD that I don't know of? I don't necessarily need this fixed, I just want sound enabled but nothing works (Installed latest ALSA). I think I want to solve this first so I know better when recompiling next time. Where to start?

BTW, I can't ask Lilo to run if any of the /dev/ are hda. I can append "root=/dev/hdax" but that failed as well.