Hi Folks,

I thought I would share this with anyone interested. I tried BT3 on the following computer. It worked fine in the end, but there were some issues initially.

Fujitsu Siemens Amilo Pro V2055 Laptop

Phoenix BIOS V1.0F-2A16-8A20
Intel Celeron-M 420 1.6GHz Processor, 533MHz FSB, 1MB L2 Cache
VIA VN800 Chipset
15.4" WXGA TFT Display
Video Processor: VIA Unichrome VN800
Intel Centrino Mobile Technology

The BIOS didn't like booting from USB no matter what I tried. I moved both USB options (USB Storage Disk, and USB Floppy Drive), to top priority in the BIOS, and nothing worked. I burned a BT3 CD, and that booted up fine of course.

Booting into BT3 Graphics mode (KDE), was ok until loading the desktop, and then everything stopped there (Black Screen).

I booted the 2nd time using BT3 Graphics VESA mode (1024x768), and that worked great.

I'm not expecting much from the Centrino Wireless Chipset (At least from what I've read so far lol).

A BIOS update might fix the USB issue, but I've not had a chance to try that yet. As soon as I get a chance though I will, and I can post back then if you like.

Thanks for a great Forum and Distro!