Hi all, my first post here.
I recently decided to get into the linux world because of a project at uni that I'm supposed to handle and since Backtrack is designed for exactly what I wanna do, I thought I'd begin with that. I installed BT4 R2 on VMware and started using it a few weeks ago but I have encountered a problem I can't seem to be able to find a solution for, thus I thought I'd ask here.

I have rented a server in EU that I have SSH access to and I'm used to set up SSH tunnel to it using plink on windows. I tried using the same method in BT4 R2 to build an SSH tunnel to my server. I simply downloaded and installed the putty-tools package and set up the SSH tunnel with the exact same command as I use in windows and everything went just fine and plink did connect successfully to my server. This is the command I use:

plink -N -D 9999 -pw password username@server_address

Problem is, when I open firefox and use as socks proxy, whether I choose socks 4 or socks 5, I always get an error saying:

"The connection to the server was reset while the page was loading.
The network link was interrupted while negotiating a connection. Please try again."

I get the same error when I use any random IP & Port as Socks in Firefox, i.e. Firefox thinks there is no active Socks connection even though plink connects just fine while doing the exact same thing on window, Firefox works just fine.

I even tried forwarding the Socks proxy using Privoxy to a http proxy (just as I do on windows to use on Opera cause Opera doesn't support Socks). In this case, in BT4, whether I set up the SSH connection or not, trying to forward Socks 4 and 4a using Privoxy, I get a message from Privoxy that "Privoxy was unable to socks4a-forward your request *page URL* through SOCKS4 negotiation write failed." trying to open any pages with Firefox and using (Privoxy's default settings) as http proxy and if I make Privoxy forward Socks5, it forwards my own internet connection rather than the SSH connection and Firefox opens pages using my own connection even though I have set its http proxy as!!

That's all, I have already wasted quite a few days trying to find what I'm doing wrong but couldn't, I'd really appreciate any help in this matter.

P.S. Same problem exists if I boot into BT using the live CD so it definitely isn't VMWare's fault.