Ive been lurking around this forum for soon a week, but this time i ran into a problem that i havnt been able to find my answer to by searching and reading here, so here we go:

starting out with my comp specc:
AMD Athlon 64 X2 Dual 4600+
2.41 GHz, 2GB RAM
GFX Card, Asus Extreme AX 700PRO, 256 MB DDR3
Motherboard, A8N-SLI Premium
and 5 different hdds.

I have booted bt3 beta on this computer before, it worked just fine. I checked the md5 hash of the file before burning it and they matched. Didnt burn at lowest speed, but the cd isnt the problem, it used to work on this computer and it still works on my laptop.

The day before yesterday i recieved my new wd raptor, and by purchasing this hdd my goal was to reinstall winxp on one partition and bt3 on another, dual booting thoose two.
I started out having problems with the sata drivers, my winxp cd being unable to boot up correctly, but in the end, after having tried alot of different things , changing sata ports and stuff, i made it work and installed winxp.

So, the next step for me would be to boot on the bt3 cd and install it on the ext3 partition i had made. Here i was unsuccessful though. First i hit the problem of having a black screen after having choosen the way to boot bt3, didnt mater which one i used. But then i tried adding bt acpi=off and i could suddenly see what was happening again.
Now it starts to load bt3 but it starts giving other errors and just freezing up.
some of the things it says are:
ata2 sata link down
qc timeout (cmd 0xef)
failed to set xfermode (err_mask=0x4)
ata 1 filed to recover some devices.

Im kinda clueless as what to do, so here i am, hoping that i gave enough information for you guys to be so kind to come up with suggestions and hopefully in the end a solution thank you