Hi !
First post, I doubt it will be the last

Got this TrendNET USB stick.

TEW-424UB (CA) H/W:3.1R (I figure out this is the rev. number)
Running lsusb on it gives me 0bda:8189 Realtek blah blah.

I crack open it to see what's inside. I attached a pic. The chip inside is a Realtek 8187B.

It is not recognized at all.

I'm using Backtrack Beta 3 latest, on HD.
At boot, BT3 doesn't even recognize it. Same thing on BT 2 Final. Tried on PC's and laptops. No luck.

I tried loading modules manually (insmod some ieee*.ko + r8187.ko) and it did not work. I tried to do exactly what's on aircrack wiki concerning r8187, no luck. Output with errors anyways (I install kernel.lzm and everything needed, turn the makefile executable, and all the stuff ...)

Any ideas ? I'm no linux expert but I can figure out many things. Last thing I would say is I tried on USB 1.1 ports, not USB 2.0 but It shouldn't matter. The stick is running fine under XP.

Previously, I had a lot of fun with a PCI Gnet crap based on a TI chipset. After 3 days, it runs perfectly under BT3 Beta, injection included, so making this Trendnet usb stick working is my next challenge.

Any comments appreciated and many thanks