Results 1 to 3 of 3

Thread: BT3 beta Atmel Usb device detection problem.

  1. #1
    Just burned his ISO
    Join Date
    Feb 2008

    Default BT3 beta Atmel Usb device detection problem.


    I'm running BT3b on an EeePc from an SD card with a persistant install. It works really well and was a joy to set up.

    Previously I've used a Usb based 802.11 device as a secondary interface on Kismet. I've ran it without problems under BT1, and BT2 and various custom Slax CD's I've made up.

    I've spent some time trying to configure BT3b to run this. With no success.

    The device is an unbranded clone, but as I said it worked fine with the atmel_usb drivers.

    lsusb shows the device detected as:

    Bus 3 Device 5: ID 12fd:1001 AIN Comm. Technology Co., Ltd AWU2000b 802.11b Stick

    A modprobe shows up no sign of the Atmel drivers.

    As far as I have ascertained support for this chipset is present in Bt3b. But as well as that I have converted the old driver that I know worked to a .lzm and inserted that in the modules directory in Boot. It loads on boot with no problem. But still fails to make any difference.

    The only thing I can think of is that BT3 dosen't recognize the device when its plugged in on USB.

    A workaround may possibly be to "fool" the system into thinking its an Atmel device. I did find a text file buried away in Usbtools directory which listed all device ID's.

    Looking at the syslog when the device in plugged in and out shows nothing.

    I would be very grateful if someone could point me to the scripts or modules I need to look at in order to find a solution for this.

    I realise there are several past threads on similar subjects, but an exhaustive search through them has revealed no answers. Similarly lengthy searches on Google and the Slax discussion boards have turned up blank.

    My main machine running Suse 10.2 detects and loads the drivers without problem.

    I think the way forward may be to change what the usb stick is recognized as, but I don't know where to start with doing that.

    Thanks in advance.

  2. #2
    Just burned his ISO
    Join Date
    Feb 2008

    Default Further Info

    Examining Dmesg when the device is plugged in or unplugged:

    usb 3-1: USB disconnect, address 8
    usb 3-1: new full speed USB device using uhci_hcd and address 9
    usb 3-1: configuration #1 chosen from 1 choice

    Not sure on the relevance of this, but I suspect that the configuration has something to do with things here.

  3. #3
    Just burned his ISO
    Join Date
    Feb 2008


    And suddenly it all becomes clear. There was no firmware file for udev to find. I downloaded the binaries and put them into the /lib/firmware directory. For good measure I also compiled the latest CVS for the driver.

    Works fine now.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts