Results 1 to 4 of 4

Thread: Setting up network on local network with bt3 over VMware

Hybrid View

  1. #1
    Just burned his ISO
    Join Date
    Jan 2008

    Default Setting up network on local network with bt3 over VMware

    I have BT3 installed on VMware. I am trying to get my eth0 set up to run on my local network so I can use BT3 to work on pentesting my other two comps.

    My localnetwork is setup as as the gateway but BT3 on VMware keeps assigning me as my default gateway. I tried changing the nic properties in VMX builder from NAT to BRIDGE, and it actually assigns the local networks info, but with no connectivity. I cant even ping the gateway. Back on my regular desktop (WINXP PRO) I ran ipconfig and it still has the VM nic assigned as I logged into my router and it shows the VM nic as present on my DHCP tables.

    How do I need to configure this so my VM runs on the same subnet as the rest of my PCs?

  2. #2
    Junior Member cyberconsole's Avatar
    Join Date
    Aug 2007


    did you try "ifconfig eth0 up" ?
    There's no fate but what we make for ourselves.

    -I already know I cant spel-

  3. #3
    Junior Member
    Join Date
    Feb 2008


    EDIT: Ah, should have read further (sorry, no sleep or food in a long while). I don't think subnetting is your problem. But if you are getting a bad gateway, you may need to change the IP settings manually. See if there is an option in VMware, or in the connection properties of the virtual network connection. I'm afraid mine worked out of the box, so I haven't had to resolve this issue. I am not certain of the konsole command to change the IP, but a quick google can get you there.

    __________________________________________________ __________
    What setting did you use for networking? NAT? Also, you may have to bridge your connections. To do this, go into control panel > network connections and highlight your virtual NIC and your real NIC, then right click and select "bridge."

    Hope that helps.

  4. #4
    Just burned his ISO
    Join Date
    Feb 2008


    Hi and excuse my english ...
    I don't know if I can help you. I use vmware on ubuntu with NAT (vmnet8). My gateway (on vmnet8) is All vm have ip from to and DNS is that my ISP. I don't use DHCP. I think you should set the ip of each your vm into range (is the WinXP that BT3).

    bye and excuse again my english :P

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts