Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: BT3Beta, trouble getting kismet started

  1. #1
    Just burned his ISO
    Join Date
    Dec 2007

    Default BT3Beta, trouble getting kismet started

    bt ~ # start-kismet-ng
    wlan0 Unknown Unknown (MONITOR MODE NOT SUPPORTED)

    Interface Chipset Driver

    wifi0 Atheros madwifi-ng
    wlan0 iwl3945 - [phy0]
    ath0 Atheros madwifi-ng VAP (parent: wifi0) (VAP cannot be pu t in monitor mode)

    kdeui (KRootPixmap): WARNING: [virtual bool KSharedPixmap::x11Event(XEvent*)] il legal selection notify event.
    kdeui (KRootPixmap): WARNING: [krootpixmap.cpp:293] loading of desktop backgroun d failed.

    Wtf is with this I've got a ubiquity src card, I click on kismet it opens, I select ath0. Then it disappears. I got the above text by typing start-kismet-ng into a console, I figure that might help provide some clues. I've been running with gutsy for a while so I know a bit about linux but I just don't really understand wtf is gong wrong with this thing. I've considered that perhaps I need to put this thing into monitor mode, but it never seems to work How the heck do I get this card to explicitly stay in monitor mode (could it have something to do with the fact that I'm using my other wireless card at the same time, so that I can keep net connectivity while I muck around with my other card, I've read some things out there that mention certain apps running can interfere with getting this working).

    I've tried adding source=madwifi (whatever it exactly was, can't remember I tried two of them, neither worked) to kismet.conf in /usr/local/etc folder. No go.

    What the heck am I supposed to do to get this working, I'm using usb key version of bt3beta

  2. #2
    Just burned his ISO
    Join Date
    Dec 2007

    Default got it

    I got tired of trying to get this to work in bt3, so I installed kismet, aircrack and a couple of other utils in my gutsy installation and it seems to be working ok.
    Took me a while to nail it, but that might have had something to do with my tx rate being lowered (which I didn't wanna set back once I got it working). I nailed 300K iv's and aircrack found the key in no time at all.

  3. #3
    Senior Member
    Join Date
    Apr 2007



    Moving to BT3.
    [CENTER][FONT=Book Antiqua][SIZE=5][B][COLOR=blue][FONT=Courier New][COLOR=red]--=[/COLOR][/FONT]Xploitz[FONT=Courier New][COLOR=red]=--[/COLOR][/FONT][/COLOR][/B][/SIZE][/FONT][FONT=Courier New][COLOR=Black][SIZE=6][B] ®[/B][/SIZE][/COLOR][/FONT][/CENTER]
    [CENTER][SIZE=4][B]Remote-Exploit.orgs Master Tutorialist.[/B][/SIZE][SIZE=6][B]™
    [URL=""][B]VIDEO: Volume #1 "E-Z No Client WEP Cracking Tutorial"[/B]
    [URL=""][B]VIDEO: Volume #2 "E-Z No Client Korek Chopchop Attack Tutorial"[/B]
    [URL=""][B]VIDEO: Volume #3 "E-Z WPA/WPA2 Cracking Tutorial"[/B][/URL]

    [URL=""][B]VIDEO: Volume #4 "E-Z Cracking WPA/WPA2 With Airolib-ng Databases"[/B][/URL]

  4. #4
    Just burned his ISO
    Join Date
    Apr 2006


    Im having the same issue with kismet just closing on me - it opens up , then asks if i want wifi0 or ath0 - it created an ath1 interface and then dies on me.
    I got an atheros chipset as well

    This all works in BT2 for me , but i broke that disc and decided to play with BT3

    I was cracking my own network and finally got it to work though i know its not the correct way.
    I have to start kismet and let it die, then start airoscript and let it run in the background - it usually does nothing but i can get the network names and macs from it.

    i then start airodump-ng seperately and 2 versions of aireplay-ng and aircrack-ng

    I get airodump running - target the network with a -1 attack and a -3 attack using aireplay-ng and have airecrack running just after i start the other programs.

    It works , but i know im messing about too much and there has to be an easier way.

    If anyone can help let me know. (even to get Kismet working properly)

  5. #5
    Senior Member DaKahuna's Avatar
    Join Date
    Jan 2010


    I have not been able to get kismet to run from the menu either but it works perfectly when I edit the /usr/local/etc/kismet.conf file and start kismet manually from the command line.

    My cards are ipw4945, atheros, and orinoco gold.

  6. #6
    Senior Member imported_spankdidly's Avatar
    Join Date
    Feb 2006


    Yes, open terminal and type


    Thanks you thank you, I'll be here all night!
    I felt like bending the bars back, and ripping out the window frames and eating them. yes, eating them! Leaping, leaping, leaping! Colonics for everyone! All right! You dumb*sses. I'm a mental patient. I'm *supposed* to act out!

  7. #7


    i am having the same issue i tried the hole open a zillion programs still no luck for some resion i cant find kismet.conf file any where im running the bt3 live cd any idea's

  8. #8


    Found it feel like a shit head lol just kept scaning over it. its all those late nites i tell you........

  9. #9


    Find the kismet.conf file use: nano kismet.conf
    go down to:
    # sources are defined as:
    and erase the last sentence and replace it with your info
    mine is source=rt2500,rausb0,RT73 this is what the paragragh should look like:

    # Sources are defined as:
    # source=sourcetype,interface,name[,initialchannel]
    # Source types and required drivers are listed in the README under the
    # CAPTURE SOURCES section.
    # The initial channel is optional, if hopping is not enabled it can be used
    # to set the channel the interface listens on.

    just put your info where mine is and it should work hope this help I had help with it yesterday.
    leave the pund sign out#.
    Dell Inspiron E1705
    Geforce 7900 series graphics card
    2G of ram
    120G harddrive

  10. #10

    Default edited the kismet.conf file

    had it running a few times and now i can not get it running any more
    im running bt3 live cd
    after i edit the conf file im getting the error like i have not its saying no no source's configed and its still reading:
    Source 0 (addme)
    in the error
    i know im doing it right its not like this is my 1st time lol
    is any one esle haveing or have had his please help
    thank you for your time (ahead of time)

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts