Results 1 to 4 of 4

Thread: Problem when booting after instalation

  1. #1
    Just burned his ISO
    Join Date
    Jan 2008

    Default Problem when booting after instalation

    hi well i am trying to install bt3 en my 500 gb usb hd, i ve tried with both usb edition and cd edition of bt3 both booting from cd/dvd and from usb (md checked before..) the followed this guide:
    The instalation finished ok but when i restart to boot from the usb hd i always get the next error:

    Im using a Maxtor oneTouch 4 500 gb usb hd
    This is my computer:
    hxxp:// uct=1840781&lang=es

    Thank you for the help and i apologize for my english wich is not really good...

  2. #2
    Just burned his ISO
    Join Date
    Feb 2008


    I have had the exact same error when trying to setup a dual boot with BackTrack3 and WinXP.

    I'm using a Thinkpad X20, PIII 600, 30GB hdd and 320mb ram.

    I created a 10gb EXT2 partition with partition magic and then booted from an external CD-ROM drive the BT3beta iso. I used the untested install proggy from the Backtrack menu.

    Installed to the new 10gb partition. Configured the lilo boot menu. All seemed fine until I tried to boot into BT3. It just hangs on that error.

    Any ideas what we've done wrong?

    DJ OD

    [I][SIZE="1"]Mostly harmless...[/SIZE][/I]

  3. #3
    Just burned his ISO
    Join Date
    Nov 2006


    Do a google search for your error. I used the following string:

    VFS: Cannot open root device "823" or unknown block

    The first return will point you back to this site where you can read and figure it out.

    Additionally, if you do another search for:

    install backtrack hdd

    You will find several links to help you. I used the link from beyondthebit which worked several times for me.

  4. #4
    Just burned his ISO
    Join Date
    Mar 2008


    I don't think this is an ancient thread so I will reply, as I just had the same problem last night. And I wasn't able to find a solid explanation. Mods since this is my first post i do appoligize if I am breaking any rules. I did read them and am just tryin to help out.

    The problem is that there is not enough time given to detect the usb drive or sdhc drive or whatever you may be using.

    To fix this, the first time you boot you will need to pause the lilo menu by hitting any button. Then type "backtrack rootdelay=10" without the quotes. This gives you 10 seconds to detect the drive and to let root mount.

    Once you have booted in, you can now make this change permanent by doing the following.

    Bring up lilo.conf with your favorite text editor, it is located at /etc/lilo.conf
    now at the end of the file add the line below, including the quotes


    now save your changes and exit. The last step you must do is go to the terminal and type lilo and hit enter to make lilo recognize the changes. Now reboot and you should be able to boot normally providing you didn't receive any errors after you ran lilo at the command line. If it doesn't work you're going to have to start googling again. Good luck!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts