when i run Kismet from the Graphique interface of Backtrack the command window opens and closes right away and when I run the command "kismet" from the command window manually I get error msg saying

Server options: none
Client options: none
Starting server...
Waiting for server to start before starting UI...
Suid priv-dropping disabled. This may not be secure.
No specific sources given to be enabled, all will be enabled.
Enabling channel hopping.
Enabling channel splitting.
NOTICE: Disabling channel hopping, no enabled sources are able to change channel.
Source 0 (addme): Opening none source interface none...
FATAL: Please configure at least one packet source. Kismet will not function if no packet sources are defined in kismet.conf or on the command line. Please read the README for more information about configuring Kismet.
Kismet exiting.

as for -deauth
when I run command

aireplay-ng -0 anth1(my wireless device) -a "the mac of the device i want to crack" anth1

i get error msg saying index number is wrong