Results 1 to 3 of 3

Thread: LILO problem on dual boot install BT3 and XP

  1. #1
    Just burned his ISO
    Join Date
    Feb 2008

    Default LILO problem on dual boot install BT3 and XP

    I just bought a new HD for my laptop and decided to install BT3 and XP on it.
    I followed the directions on the wiki except I used the BT3 installer.
    Appears that something is wrong with my LILO.
    I keep getting the following error when running lilo -v,
    Fatal: raid_setup: stat("/dev/hda")

    Below is my lilo.conf and an fdisk -l
    hda4 is my root partition on my BT3 install, and hda1 is my XP install.

    Lilo Config: (chroot /mnt/hda4 /bin/bash)
    boot = /dev/hda
    timeout = 15
    #vga = 769,771/773/792
    vga = 769
    image = /boot/vmlinuz
    root = /dev/hda4
    label = BackTrack


    bt ~ # fdisk -l
    Disk /dev/hda: 120.0 GB, 120034123776 bytes
    255 heads, 63 sectors/track, 14593 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes

    Device Boot Start End Blocks Id System
    /dev/hda1 * 1 14083 113121666 7 HPFS/NTFS
    /dev/hda2 14084 14092 72292+ 83 Linux
    /dev/hda3 14093 14217 1004062+ 82 Linux swap
    /dev/hda4 14218 14593 3020220 83 Linux

    bt / # lilo -v
    LILO version 22.8, Copyright (C) 1992-1998 Werner Almesberger
    Development beyond version 21 Copyright (C) 1999-2006 John Coffman
    Released 19-Feb-2007 and compiled at 01:09:42 on Jun 10 2007.

    Fatal: raid_setup: stat("/dev/hda")

    Any help is much appreciated.
    Thanks in advance.

  2. #2
    Join Date
    Mar 2007


    Follow the dual boot video and you will not only get a better install, you will gain a small amount of command line knowledge and more importantly you will see the part where you went wrong. Whats happened is you are trying to execute lilo from the disc which does not work. You need the chroot command to get into your hard disk you just installed. Again do the dual boot video on the wiki. It was made by backtracks core developer. Anyone who doesn't do it that way is not to smart in my opinion

  3. #3
    Just burned his ISO
    Join Date
    Feb 2008


    Thanks pureh@te if you look at my lilo.conf you can see I did CHROOTed to my root install hda4. I solved this problem soon after I posted this.

    All I did was rebooted and lilo showed up (which did not happen before) it just backtrack on it, not XP.

    So I then I booted to BT3 using lilo and nano'ed my lilo.conf and windows was in there, so I then tried a lilo -v and everything worked this time. Not quite sure why the chroot of the hda4 did not work.
    Anyways everything boots fine now. Thanks for you help.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts