Tutorial how I got compiz to work with hdd install on an Intel 945GM chipset laptop. (Intel810-i950 / Compaq nx7300)
You will need two things.
1. Partition Magic found Hiren's BootCD (google or torrent sites, it´s freeware)
2. Bootable version of the DVD (USB) Version bt3 (Extended) Size: ~ 946 MB
read: htt*://forums.remote-exploit.org/showthread.php?t=11091

First I formatted the hdd with Partition Magic found on Hiren's BootCD with EXT3 file system.
Booted the computer with the bt3 DVD and choose first option bt3 (kde) in the boot menu and let it boot up,
in K menu you will find “backtrack” and then go for “Install BackTrack (not tested)”
Choose real install, and then wait till it’s finished, turn of computer and remove DVD.
Boot the computer and login in with root/toor and startx and reinsert DVD in tray.
Now we are going to copy the cubez.lzm from the bt3 DVD to root folder, it’s located in BT3/optional.
Done? Ok, then you opens a terminal window ant type: lzm2dir cubez.lzm /
And wait a few seconds to finish,
go to /etc/X11 folder and open up xorg.conf
(It will open in a text editor) and ad these lines at the very end of the .conf file.

Section “Extensions”
Option “Composite” “Enable”

Save the xorg.conf file and close all windows and turn off the computer. (Don’t forget to remove the DVD)
Boot up the computer one final time login with root/toor
But this time we are going to start the system with the following command:
Now x starts and you should have working compiz (you will se 8 desktops in tray)
Navigate cube with:

<Ctrl><Alt>Right/Left (Arrow Key) ... Rotates cube right/left to next plane/side.

<Ctrl><Alt>Down (Arrow Key) ... Pans out to plane/slide; use right/left to select view, then release all to return to normal.

<Ctrl><Alt>Up (Arrow Key) ... Organize all windows on-screen; use right/left to select one, then release to activate it.
(On my install Shift-Alt + Up (Arrow Key) worked)

<Ctrl><Alt>Button1 (mouse button 1) ... Hold down mouse button 1 to "hold" screen and rotate cube manually.

If you don’t like the command line logon and want the KDE desktop to start automatically. Type in terminal: nano /etc/inittab change the following line: id:3:initdefault to id:4 exit and save.

There is most sertenly easier ways to make it work, but this is the way I NOW it will.

Hope this will be to some help.