Results 1 to 4 of 4

Thread: BT3 with issues with integrated video + workaround

  1. #1
    Just burned his ISO Darkpaw's Avatar
    Join Date
    Jan 2008

    Default BT3 with issues with integrated video + workaround

    Would have posted this in non-working hardware, but as I don't have posting rights I am posting it here. Hopefully, this will help some others with video issues on certain integrated chip sets.

    I have a bit more then a years experience using BT2 and some Linux knowledge, but had not spend much time messing with the video configuration. On BT3 I ran into a problem on some of my lab systems where x windows wouldn't work and changing the resolution, using xconf, or booting into VESA mode didn't help.

    I was working on an Optiplex GX150, however the issue seems to be related to the driver for the Intel i810 family, which is found in many systems.

    If you are getting the problem where x windows won't start due to the BPP32 not supported error, you can do the following:

    open /etc/X11/xorg.conf in your favorite editor
    add the following line:

    DefaultDepth 24

    some place between the Section "Screen" and first SubSection "Display" lines.

    Save the conf file and startx, it should work fine now.

  2. #2
    Junior Member MisterCrash's Avatar
    Join Date
    Nov 2007


    ummmm, i believe it should already say this if you chose 24 bit color as default when setting up xorgconfig. even with this in place it doesn't support my 82845G. I just posted a thread about this earlier. The strange thing is, The generic Intel i810 driver worked great for me in BT2 with a properly configured xorg.conf. I still have no support for it in BT3 no matter what I try. Obviously the same goes for my slack 12 install. There must be some major change between Slack 11 and 12 maybe it's a new version of X11. I still havent figureed it out. Gonna have to deal with VESA for now.........

  3. #3
    Just burned his ISO
    Join Date
    Jan 2008


    im having "unable connect to x server" when i startx.why is dat happening?can it b fixed with adding the extra line ? N can i edit it when im in windows xp? thnks

  4. #4
    Moderator KMDave's Avatar
    Join Date
    Jan 2010


    Well it can be fixed with some research of your own.

    Sorry but you seem to have not a real clue about Linux at all and therefore should try to learn about Linux before using BT.
    Tiocfaidh ár lá

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts