Have used various of BT and some may remember me from a year or so back but I have a strange issue on one particular USB key (got given it its 2gig)

have used BT on other usb sticks but this one is weird I cant get the USB to boot

I tried the bootinst.bat with the following output :-

Setting up boot record for F:, wait please...
Reading boot sector: The parameter is incorrect.
Disk F: should be bootable now. Installation finished.

Read the information above and then press any key to exit...
So I did some poking about mounting it with a VM of BT2 repartitioned etc etc

QTparted seemed to have an issue with the drive having a cluster size of 2048 and so did the bootinst.sh script in the /boot folder

so I went back to windows and tried this :-

C:\Documents and Settings\CurioCT>format f: /FS:FAT32 /A:512 /X
Insert new disk for drive F:
and press ENTER when ready...
The type of the file system is FAT32.
Verifying 1945M
The specified cluster size is too small. The minimum valid
cluster size value for this drive is 2048.
which seems to me I cant format this stick for 512?

is this all red herring or is it the reason i cant get this stick to boot?

or is there something else can anyone help?