this morning when i decided to put bactrack2 on my brand new maxtor onetouch4 500gb i burned the iso image (perviously md5 checked) to a cd-r at burning speed 2x.
And when loading i keep getting this error:

then the start just stops. somethimes i aslo get an error with both hdd and hdc.
When i saw this i looked for that problem but just got some articles related to a n ubuntu install. and just one to backtrack in the french forums without an answer.
In my search i found this post too:

so i followed the instructions and when finished booted from the external usb hd the same error occourred.

I am thinking i could use hdparm to disable dma on hdc and hdd. They are the dvd-reader and dvdw(i think how could i confirm this?)

Can't post url updating when i can...

I entered the irc channel and one of theguys there (srry i dont remember the name) told me that this problem had something to do with the cd-rom as i tought at first and a friend of mine told that i should try booting without the cd readers so i unplugued both and tried booting form the usb harddrive it worked, so i plugged one in (dvd writer) and i got the same error, unpluggedit and plugged the other one (dvd reader) it worked fine i was able to boot without problem. so now i now that the problem was de dvd writer:
Unidad LightScribe DVD(+/-)R/RW (+/-)R DL 16x
my pc:
hxxp:\\ uct=1840781&lang=es#N330

Any suggestions???

---Update 2---
I have managed to start using the nohotplug option.