Results 1 to 3 of 3

Thread: USB install

  1. #1
    Just burned his ISO
    Join Date
    Dec 2008

    Default USB install

    I've been trying to install backtrack 3 onto my flash drive. I've followed many tutorials and still I'm not able to get this right. Here's the list of steps I did
    1) got the bt3final USB to my computer checked the md5sum
    2) plugged in my new flash drive
    3) downloaded lexar's usb format tool to change the removable bit on the flash drive removed and plugged back in.
    4) went to windows disk management area. Formatted the usb drive into two partitions one 1 gb FAT32 partition and the rest is extended partition (4 gig drive)
    5) copied filed into the new drive with both winzip and 7zip. (not on the same try of course)
    6) went into the usbdrive/boot and ran bootinst

    I get the message Not a removable drive (use -f to override)
    So I tried to open the command prompt tried cd g:/ but I guess windows is still sticking in the windows root dir... I tried anyways "(drive):\boot\bootinst.bat" -f it was saying it was going to write the mbr for my root drive so I closed the screen.
    So I deiced to try to make a shortcut to bootinst.bat and add -f at the end still it does not work.

    So now I'm stuck I'll really like to put this tool on a USB drive. I think I'm going to look for a VM tutorial


  2. #2
    Developer balding_parrot's Avatar
    Join Date
    May 2007


    This should answer your questions.
    It is for BT2 but all the steps apply to BT3 too.
    It also covers the -f switch

    BTW there was no need to mess with changing the removable bit, it is not required at all.

  3. #3
    Just burned his ISO
    Join Date
    Dec 2008


    Yeah thats great I didnt see that tutorial. I'm sorry I feel like an ass when I ask a question that was answered. Thank you

    Thanks that worked it forced it though. Heh now my usb drive is not picking up maybe I missed something or just messed something up. Here is a list of steps I tried:
    1) changed the bootinst.bat to what your post stated.
    2) tried a rebot changed the settings to boot from the usb drive tried everything usb-fdd, zip, rom ,hdd all options for usb.
    3) figured I didnt do something right found a file called make iso in the bt3 folder and pointed it at a file that was in a folder called [boot] let that run
    4) then i used HP's drive key utility tried ran it. I forget what the options where I think the one was floppy and the next I pointed it to that iso file that was in the [boot] folder
    5) tried everything again and nothing
    I noticed that the usb drive is comming up as a hard drive that sounds normal but nothing I do makes it boot up. I tried putting the usb drive above the hdd in the boot sequence too.

    I also figured Id try it again but it does not show up in windows now.. It makes the sound when I plug it in and pull it out but does not show...

    I don't feel like going out now and buying a new usb drive as cheap as they are lol. If I cant figure this out tomorrow I'll just try installing it though VM ware or just normally on my harddrive.
    Thanks again

    Ok I got it to work for anyone that has this problem (probably only me) heres what I did. I went into the disk manger in windows. It asked me about installing a new drive I formatted it the same way as before 1024 mb for the primary and the rest is the extended. I then followed the instructions given above. The only thing I had to make sure is that the usb stick was above my main hdd on the boot sequence. Now it works very well I've been playing with it for the last couple of minutes. Now I got to get used to linux and learn some more about this program.

    Thanks balding_parrot for the tutorial!

    I'll be looking at the training courses I'm not sure if I am going to do them, but the demo video was pretty helpful.

    I also got the book Penetration Tester's Open Source Toolkit(where I found out about this program)

    Again thanks I'll probably be around the forums when I get stuck again or have questions

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts