Results 1 to 4 of 4

Thread: Merry Christmas ;) - BT3Beta USB Help

  1. #1
    Member imported_Deathray's Avatar
    Join Date
    Oct 2007

    Smile Merry Christmas ;) - BT3Beta USB Help

    Just got a 2gb usb pen drive from my dad and wanted to use
    one of them for BackTrack 3 Beta of coarse.
    Well I formatted the usb Fat32 file system and ran the
    Rebooted my pc and everything is working perfectly . Except for one thing
    that I'm guessing has a simple answer. When I reboot, any changes that I've
    done, gets lost. I want the usb to act as a real install.
    So first thing I did was do some research on my own.
    I found out (from the BackTrack wiki) that in order to save changes, you have to run
    dir2lzm /mnt/live/memory/changes changes.lzm
    from the terminal. So I tried, but when I rebooted, everything was still rolled back
    to default.
    Now, is there a way to make the usb act as a real installation? Maybe use the
    "Install Backtrack" as real on the usb pen?
    Or maybe I'm simply missing something?
    What are my options?
    - Poul Wittig

  2. #2
    Member imported_Deathray's Avatar
    Join Date
    Oct 2007


    - Poul Wittig

  3. #3

  4. #4
    Just burned his ISO
    Join Date
    Dec 2007


    I'm trying to do a real install of the USB live version (the 900 megger, expanded to about 3.4 gig or so when doing 'real' FYI).

    So far I cant get it to fully work and I have a few guesses why but I'm not sure. So if anyone in this thread pops up with some info that would be awsome for us both.

    First off, I have a 1 gig, 2 gig, and 4 gig USB stick. I put the latest beta3 on my 3 gig, it was formatted FAT32, ran the by booting the beta3 CD (the smaller one with less neato keen stuff :[ )

    That worked fine. I have the live USB 900 meg booting prefect, though some software seems broken or needs a lot of configuring.

    Now, I did a real install to the 4 gig FROM the 2 gig USB. On first boot on the 4 gig real, I kernel panic'd with RAID issues? wtf? and something about VFS: fix value for either boot or root="". I dont have the error directly on hand as this is my only box and I cant copy the kernel panic excat yet. I will add it to this pos tlater if possible.

    So, I booted the CD assuming that the device namin by USB probably broke the install (2 gig was sda, 4 was sdb, but then on first reboot the 4 gig would now be SDA to boot)

    Mounted it, then mounted proc and bind from the 2 gig live USB image, to the 4 gig mounted spot, then chrooted to the 4 gig and configured lilo. Once that was all set to have sda properly referenced I ran it, I received quite a few warnings but nothing fatal.

    On boot I still kernal panic, similar error that was the oher one listed above (either root or boot=) and osme file system stuff.

    I'm sure is the kernel and something is odd with it. When using the GUI backtrack install in beta 3 from a USB stick to another stick what kernel does it use? The normal live ISO image one it uncompresses has no problems but the one the 'real' install seems to put in place must be ifferent or missing osmething.

    Is ext3 support compiled in? Are there any specific cfdisk partition options I need t obe aware of? Is there something wrong with the kernel that gets installed with the BT 3.0 UNTESTED gui installed and is there a way to get around it? I've searched and found bits and pieces of info, but nothing that seems to lead me from A to B.


    Sorry for the hijack btw, but if you want to do a real install then you will run into some issues as well..

    Also, To setup the USB stick you literally only have to follow the instrucitons on the install or readme.txt, whatever its called. There is even a batch file to be run FROM THE STICK IN WINDOWS, but be careful to be CD'd TO the USB stick to run it, and it will try to read your windows partitions and add them into its auto fstabbing.

    -f0'sheezzzzzzyy freeezzzzzyy

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts