OK, I have put BT3 onto a USB stick with persistant changes enabled (it seems to work great). I have blacklisted the orinoco / hermes drivers and enabled the hostap_cs drivers.

I also downloaded the patched version of hostap as shown above from *ttp://yousuck.dk/hostap.tar.gz and replaced the folder in /lib/modules/

Rebooted, inserted the Senao. No error messages I run the modprobe hostap_cs from console just to be sure.

Run airodump-ng which works great as the sensitivity of this card is excellent.

Tried running the injection test airplay-ng -9 wlan0 = failed and no AP found.
Run command ifconfig wlan0 up (to be sure again)
Checked the card was in monitor mode = yes

Run the injection test again = failed no AP found.

I then forced the Wlan0 interface onto channel 4 and run the injection test again.

Trying broadcast probe requests...
Injection is working!
Found 2 APs etc etc.

I am unsure why initially forcing the card to listen on a channel activates the drivers / interface so any further comments welcome.

Just a quick question though. As so many people tend to use this card or a re branded variation it would be nice to see it supported a bit better on the final release.

Anyway, thanks for the thread and info - Off to install the full version to HDD as I can now inject with the Senao.