Page 2 of 2 FirstFirst 12
Results 11 to 12 of 12

Thread: problem when starting startx on notebook

  1. #11
    Junior Member
    Join Date
    May 2007


    Quote Originally Posted by GrizlyJee View Post
    I have the same problem.

    Tried looking for something like that but didn't find anything.

    I also entered xconf before startx but I keep getting the same error!

    I can run it in VESA mode or something like that though, chosen from the option menu before linux starts loading.

    I got a Toshiba Pro P200 laptop.
    I have the same Toshiba laptop, and the same problem...I have no idea, how to solve it, I've tried many of xorg config files.
    Perhaps the ati.lzm will help us, before I try everything on an external monitor.

    DOMy sweety

    Home, sweety home

    -by HK!

  2. #12
    Senior Member secure_it's Avatar
    Join Date
    Feb 2010
    在這兩者之間 BackTrack是4 FwdTrack4

    Thumbs up

    Quote Originally Posted by elemmakil View Post
    when i start backtrack, it boots normal, then i log in.

    when i type startx now i get a error message telling me
    (==)Log file: "/var/log/Xorg.0.log" Time: Fri Dec 14 14:11:22 2007
    (==)using config file : "/etc/X11/xorg.conf
    (II) Module already built in
    (EE)VESA(0): No matching modes
    (EE)Screen(s) found, but none have a usable configuration.
    Fatal server error:
    no screens found
    giving up.
    xinit: Connection reset by peer (errno 104): unable to connect to X server
    xinit: No such process (errno 3): Server Error
    I get the same message when i type xconf and then startx =(
    I am using a HP Compaq 6715s notebook (screen resolution: 1280x800)
    I have the problem with Backtrack2 and with Backtrack 3, too.

    Can anyone help?

    greets elemmakil
    either configure /etc/X11/xorg.conf and put the desired resolution there and keep the color depth to default 24 and exit
    then run startx

    still not solved the problem?

    there should be more then 1 xorg.conf file like xorg.conf.orig or xorg.conf.backup or xorg.conf.old
    then copy the backup file over orignal xorg.conf
    run startx

    still not solved final solution

    this will solve your would replace the xorg.conf file with the original/fixed one.

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts