Results 1 to 3 of 3

Thread: Lilo conf issue with dual boot vista / backtrack

Hybrid View

  1. #1
    Just burned his ISO
    Join Date
    Dec 2007

    Default Lilo conf issue with dual boot vista / backtrack

    Here is my problem. I just made my dir's, copied the live cd over, created lilo file and now my system will not boot into windows any more.

    Info: Acer Aspire 5100 Laptop
    bt ~ # fdisk -l

    Disk /dev/sda: 120.0 GB, 120034123776 bytes
    255 heads, 63 sectors/track, 14593 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes

    Device Boot Start End Blocks Id System
    /dev/sda1 1 1019 8185086 12 Compaq diagnostics
    /dev/sda2 * 1020 7826 54677227+ 6 FAT16
    /dev/sda3 7827 10090 18185580 7 HPFS/NTFS
    /dev/sda4 10091 14593 36170347+ f W95 Ext'd (LBA)
    /dev/sda5 10091 10099 72261 83 Linux
    /dev/sda6 10100 10224 1004031 82 Linux swap
    /dev/sda7 10225 14593 35093961 83 Linux
    lba32 # Allow booting past 1024th cylinder with a recent BIOS
    boot = /dev/sda
    #message = /boot/boot_message.txt
    timeout = 1200
    # Override dangerous defaults that rewrite the partition table:
    # VESA framebuffer console @ 1024x768x256
    vga = 773
    # Windows bootable partition config begins
    other = /dev/sda4
    label = Windows
    table = /dev/sda

    # Linux bootable partition config begins
    image = /boot/vmlinuz
    root = /dev/sda7
    label = Linux
    # Linux bootable partition config ends
    *Note* I have tried changing the default windows drive fro sda4 - sda7
    Each time when Lilo loads and I tell it to boot windows it takes me into the Acer eRecovery System. This system seems to just overwright system files, it will not actually correct the mbr or reinstall vista.

    I'm not figuring this issue out and would appreciate a fresh pair of eyes to take a look and see if you can see what i'm doing wrong here.

    Thank You,

  2. #2
    Junior Member
    Join Date
    Dec 2007


    Let me preface by saying I'm new to Linux/Slackware/BT2 so take my ideas with a grain of salt... to my credit, I have read and read and read till my eye has bled and hopefully, I've picked up some info that might be of help.

    You're running Vista, of which I'm unfamiliar, but I suspect it's on NTFS which is /dev/sba3 from the looks of things...

    sba4 appears to be an "extended" partition so it's not a PRIMARY (only 4 primary are permitted on most drives as I understand it). and also appears it might be a FATxx partition based on the W95 info... unclear as to that.

    The last 3 partitions makes it appear you're using one of the guides which suggests making a small "boot" (possibly 1-1.5 megs) for the /boot directory/files (sba5) with sba6 being a separate "SwapLinux" partition and sba7 being a larger and 2nd Linux partition for all the rest of the BT2 directories files.

    If that is so, it seems your lilo.conf should point to sba3 for Windows booting

    lilo.conf should point to sba5 if that is where you put the "boot" stuff (which is likely as per the guides I've read); otherwise, use your sba7 if that is where your BT2 "boot" stuff.

    Your final 2 lilo file commands, after editing lilo.conf is

    <CTL> w = write your lilo.conf file changes

    lilo -v = writes the lilo to MBR which you appear to be doing correctly

    reboot computer when done with 1 and 2 above

    I'm still struggling on getting BT2 installed on my laptop and I initially tried with the 3 partitions; however, it appears to make life much easier to simply use 1 Linux partition for all the files/data and 1 LINUXSWAP partition.

    BTW, I am writing this post on my laptop using Firefox off the BT2 Live CD loaded into memory (because I can't get the darned thing installed on my HDD as yet) and can surf around the net fine... just so you don't get too discouraged, I blizted my XP MBR 3 times now where my computer wouldn't boot at all--either to XP or BT2; however, a nifty free net d/l got my MBR repaired easily and swiftly... and I've followed the WiKi guide, parrot's guide, the "transcript" guide, the Wiki movie, the BT INSTALLER program (both) from within the GUI and several others having tried BT2 HDD install 8 times now unsuccessfully... most of my hang ups seems to be down in getting the lilo.conf to successfully write to my MBR which I get errors of conflicting partition table info or else the guides differ and I just haven't found 1 complete, step-by-step, that'll get me running from my HDD...

    Do hang in there; folks here are most knowledgeable and the SEARCH button is your friend...

    If the guru's find an error above, please let me know and correct it... i'm a "noob" to Linux, but learning as fast as I can and am a Mod and a Super Mod in some sat forums so I'm pretty aware of how/what to post.. and I'll ask my questions in a separate thread...

    Good luck, jimmyb!

  3. #3
    Join Date
    Mar 2007


    What did your partiton table look like before you tried to install bt and what does it look like now? What guide are you following? it does look like your windows is on sda 3.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts