Results 1 to 3 of 3

Thread: E: Sub-process /usr/bin/dpkg returned an error code (1)

  1. #1
    Just burned his ISO
    Join Date
    Jan 2010

    Default E: Sub-process /usr/bin/dpkg returned an error code (1)

    I'm trying to customize my BackTrack4 image so I can use the live disk with my ati graphic card. While trying to put the drivers with the apt-get install ati-driver command, I get the following message:

    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    The following NEW packages will be installed:
    0 upgraded, 1 newly installed, 0 to remove and 1 not upgraded.
    Need to get 0B/17.8MB of archives.
    After this operation, 86.0MB of additional disk space will be used.
    (Reading database ... 233992 files and directories currently installed.)
    Unpacking ati-driver (from .../ati-driver_9.5-bt2_i386.deb) ...
    Replacing files in old package libgl1-mesa-glx ...
    Replacing files in old package xserver-xorg-core ...
    dpkg: error processing /var/cache/apt/archives/ati-driver_9.5-bt2_i386.deb (--unpack):
    trying to overwrite `/usr/lib/', which is also in package libgl1-mesa-dev
    Processing triggers for man-db ...
    Errors were encountered while processing:
    E: Sub-process /usr/bin/dpkg returned an error code (1)

    I tried everything that I could find searching the net, but I couldn't solve the problem. Does anyone have an idea how to solve the problem?


  2. #2

    Default Re: E: Sub-process /usr/bin/dpkg returned an error code (1)


    this error just means package ati-driver_9.5-bt2_i386.deb can't be installed through some errors.

    Don't run X11 if you install new X11-core/graphic related libraries (press ctrl+alt+backspace) and try to install again with command
    dpkg --force -i /var/cache/apt/archives/ati-driver_9.5-bt2_i386.deb

    If it still not working, you have to enable a more verbose output, like
    dpkg -D1 -i /var/cache/apt/archives/ati-driver_9.5-bt2_i386.deb
    dpkg -D40 -i /var/cache/apt/archives/ati-driver_9.5-bt2_i386.deb


  3. #3
    Join Date
    Jan 2010
    Helsinki, Finland

    Default Re: E: Sub-process /usr/bin/dpkg returned an error code (1)

    Its a bug - check BT4 bugs, try to live now without ati driver and wait until it gets a fix

Similar Threads

  1. Bt- 4 serieas problem error error
    By lenien in forum Beginners Forum
    Replies: 2
    Last Post: 01-18-2010, 06:52 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts