Originally, I was unable to connect to the internet at all, but I've worked through this problem a bit on my own. When I was first unable to connect to the internet, the output of ifconfig wlan0 was

root@bt:/etc/resolvconf/run/interface# ifconfig wlan0
wlan0 Link encap:Ethernet HWaddr 00:1f:3c:48:08:86
inet addr: Bcast: Mask:
inet6 addr: fec0::b:21f:3cff:fe48:886/64 Scope:Site
inet6 addr: 2002:44b4:14ef:b:21f:3cff:fe48:886/64 Scope:Global
inet6 addr: fe80::21f:3cff:fe48:886/64 Scope:Link
RX packets:5113 errors:0 dropped:0 overruns:0 frame:0
TX packets:483 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:838013 (838.0 KB) TX bytes:43790 (43.7 KB)

which obviously seems strange because I have 3 ipv6 addresses. The first time I noticed the error, I actually had 6 or 7. I tried restarting the network, which didnt help. I also tried restarting my entire system, which also didnt help. I noticed an error during boot that said in red

/etc/rcS.d/s07resolvconf: line50: /etc/resolvconf/run/enableupdates: read only file system
failed (could not enable updates)
I tried to copy that down on a piece of paper as it flew by on boot, so if there appears to be a spelling mistake in there, it's probably my fault. I finally was able to resolve this problem by going to /etc/resolvconf/run/interface and deleting wlan0.txt. I got this idea, because I saw another error go by during boot that said something along the lines of being unable to remove that file. After another reboot, I was able to connect to the internet normally.

So now I can remove that file manually after boot, then reboot, and I can connect wirelessly. This is not ideal. I dont recall modifying my system in any way before this problem occurred. Any idea whats wrong? If you need the exact boot errors I'm receiving, please let me know the location of the boot logs. Thanks