Hello there to all of you!

I promise I read and read and read everything in Google to solve this issue but didn't find ANYTHING, except adding some boot commands which didn't work.

Im running:
Intel i5 2500, Asus P8H67-M pro, 4GB Ram Gskill RipjawsX 1333Mhz, Windows 8 64Bits installed in Seagate 500GB Sata3, another 2TB WD Green Sata3, MSI GTX560Ti Twin Frozr II, with BackTrack 5RC3 Gnome 64Bits in a Verbatim 32GB 3.0 Store 'N Go Usb drive.

I have a D-Link AirPlus G DWL-G510 Wireless PCI Adapter(rev.C) card, and because VM Stations don't recognize PCI cards, I installed BackTrack 5rc3 into a 32GB Store 'N Go Verbatim 3.0 USB drive. I got it working after setting this drive in BIOS to HARD DRIVE. It worked like a charm WITHOUT THE PCI card connected. I shutted down my PC, installed the PCI card, booted Windows 8 and it worked, could connect to wifi networks, etc. I rebooted and booted the usb drive and I chose the second option (default text boot) to login and startx after that but after the BackTrack background appeared, the CMD line appeared but it entered in a loop.
This loop was:
DMAR:[DMA Read] Request device [07:00.0] fault addr fffdf000
DMAR:[fault reason 02] Present bit in context entry is clear
DRHD: handling fault status reg 3

And that is repeated like 5 times per second.

Now I think that 07:00.0 belongs to wireless PCI card, according to my google searches.

I don't know what else I might add to help resolving this problem in an easier way. I really tried and tried but I can't get it to work.

Thank you all for taking the time to read, and I hope someone has an answer to this issue.