Hi, This is my first post iv just joined the BT foum

Installing Ettercap
(Linux Backtrack 5R3 gnome)
I know there are a lot of install guides for this out there and a lot of this ground will have been covered in other posts, I would like to share how this worked for me. As you already know ettercap is installed ready to go when backtrack is used. I chose to dedicate and unused laptop to backtrack therefore installing this to the hard drive. From the beginning I have suffered from one of the bugs that many face. After scanning for hosts the session closes. Here is how I worked around this and the errors I encountered on the way. With backtrack being a clean new install I installed and configured a few things which I will document along the way. This may or may not have had something to do with the functionality in the end.

NIC Configuration
I started by configuring my NIC’s so I could disable the on board wireless card to prevent chances of conflict with my USB Alfa Networks AWUS036H.

(nano /etc/network/interfaces)

My on board wireless card was identified as Wlan0, I comment this out so this would no longer be seen by the system (# to comment out) Ctrl + X to save and Y to exit, I then run the following to restart the network (/etc/init.d/networking restart). Once the network had restart I used ifconfig to verify I could only see my loopback interface and Wlan1 (Alfa card)

SPM Install
After configuring the NIC I chose to Install Synaptic Packet Manager (apt-get install synaptic) which allowed me to completely uninstall Ettercap form the system. I removed all possible packages so this was no longer visible in the menu.

System Update
When the install of SPM was complete I updated the system running (sudo apt-get update) followed by (sudo apt-get dist upgrade) – This can take a long time.

Libpango and libgtk
Next came the install of these two components. Instead of installing them both together I installed them one by one

(apt-get install libpango1.0-dev –fix-missing)

I ran this with the fix missing extension as the first attempt was unable to fetch some archives. This gave me a successful install.

(apt-get install libgtk2.0-dev)

When installing this I was faced with the error

“The following packages have unmet dependencies:

Libgtk2.0-dev: Depends: libgtk2.0-0 (=2.20 1-0 0unbuntu2.1 is to be installed
Depends: libxi-dev (>= 1:1.0.1-4) but is not going to be installed
Broken packages

To resolve this I carried out the following.
I checked my repositories (cat /etc/apt/sources.list)

I had the standard backtrack repos

deb http://all.repository.backtrack-linux.org revolution main microverse non-free testing
deb http://64.repository.backtrack-linux.org revolution main microverse non-free testing
#deb http://source.repository.backtrack-linux.org revolution main microverse non-free testing
deb http://updates.repository.backtrack-linux.org revolution main microverse non-free testing

I added the following repositories by editing the source list


deb http://archive.ubuntu.com/ubuntu/ gutsy-updates main restricted universe multiverse
deb-src http://archive.ubuntu.com/ubuntu/ gutsy-updates main restricted universe multiverse

Ctrl + X followed by Y to return to the terminal and save the repos.

(apt-get update) to update the packages

Finally (apt-get install libgtk2.0-dev)

Libent & Ettercap
I downloaded Libnet from the following site http://linux.softpedia.com/progDownl...oad-10275.html and placed the libnet- in the root folder

I then went on to extract the file to the directory (tar -zxvpf /root/libnet-
Then I went on to compile the install

(cd /root/libnet)
root@bt:~/libnet# ./configure
root@bt:~/libnet# make
root@bt:~/libnet# make install

I downloaded the latest ettercap from the ettercap website currently ettercap- and saved this to my root directory.

Next I extracted ettercap (tar -zxvpf /root/ettercap-
Then went to compile the install “advised by the latest version”

(cd /root/ettercap-
root@bt:~/ettercap# mkdir build
root@bt:~/ettercap# cd build
root@bt:~/ettercap# apt-get install cmake
root@bt:~/ettercap# cmake ../
root@bt:~/ettercap# make
root@bt:~/ettercap# make install

Ettercap now works every time.

Hope this provides some use. I understand different people will experience different issues, I just thought I’d share mine