hi, I am having a lot of difficulties getting rubygems1.9.1 to install. Every time I try, get this message:

root@bt:~# sudo apt-get install rubygems1.9.1 Reading package lists... Done Building dependency tree Reading state information... Done Suggested packages: rubygems-doc The following NEW packages will be installed: rubygems1.9.1 0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded. Need to get 0B/201kB of archives. After this operation, 864kB of additional disk space will be used. Selecting previously deselected package rubygems1.9.1. (Reading database ... 397621 files and directories currently installed.) Unpacking rubygems1.9.1 (from .../rubygems1.9.1_1.3.7-1~uorppa0_all.deb) ... Processing triggers for man-db ... Setting up rubygems1.9.1 (1.3.7-1~uorppa0) ... update-alternatives: error: alternative gem can't be master: it is a slave of ruby dpkg: error processing rubygems1.9.1 (--configure): subprocess installed post-installation script returned error exit status 2 Errors were encountered while processing: rubygems1.9.1 E: Sub-process /usr/bin/dpkg returned an error code (1)
I have tried multiple steps from searching google to try to remove it completely to reinstall, but none seem to have worked yet.

The commands include
sudo apt-get clean
sudo apt-get autoremove
sudo apt-get -f install 
sudo apt-get remove rubygems1.9.1
sudo dpkg --configure -a
sudo dpkg -r rubygems1.9.1
sudo dpkg -P rubygems1.9.1
sudo apt-get install -reinstall rubygems1.9.1
sudo dpkg --remove --force-remove-reinstreq rubygems1.9.1
sudo apt-get remove --purge rubygems1.9.1
sudo apt-get -s remove --purge rubygems1.9.1
locate rubygems1.9.1 (then rm -rf all of the locations listed)
sudo gedit /var/lib/dpkg/status (searching for rubygems1.9.1 and removing that entire block)
So far, I have had no luck and each relevant step was followed by a sudo apt-get update && sudo apt-get install rubygems1.9.1

Any help with this would be outstanding.