Alright, this problem arose just overnight, the day before ettercap as redirecting websites just fine but today, i get nothing.

These are the steps that I put together and used, and it worked many times.

nano /usr/local/share/ettercap/etter.dns

Change website address to redirect, and ip to redirect it to. Save with Ctrl+o then enter.

Open ettercap-gtk

Sniff –> Unified Sniffing

Host, Scan for hosts. Add the router to target 1, and the others to target 2

Mitm > arcp poisoning > sniff remote connections

start scanning

Plugins > manage plugins > dns_spoof plugin

However, today I can't get it to work, and I've done everything i can think of short of reinstalling the OS. These steps worked perfectly fine yesterday, so I don't get whats going on. The section that shows when the target attempts to access the webpage just stays empty, and the target is un-affected.

So, what is the fix for this?

Also, can I select just one or two targets from the command line, and have it work the same? I'd rather do it that way that dealing with the GUI