I am new to BT5R3 OS and i just installed it into a VMware node just to find possible security issues of my private LAN.
I already knwo that when BT5 is running through a VM it can not access implicity the on-board wifi antena of my laptop and that's why i bought a usb-wifi adaptor which is the AWUS036H from ALFA Networks (Also i have to mention that my wifi router is the D-LINK DIR-615 ).
Now, before starting using the BT5 OS i first checked the status of the wifi-usb adapter by firslty using it through a Windows 7 OS. As i expected the usb-wifi adapter connected succesfully to my router and i pinged succesfuly the default gateway of my router(the known url address ). Moreoever when i was inserting to my router's control panel - through my desktop - i could see my wifi's MAC address. So far so good.

Unfortunately the problems started when i tried the usb-wifi adaptor through the BT5 OS.
In simple words after i logged in i connected the wifi adaptor and then accessed the pre-installed drivers. I brought up the wifi' s interface and after scanning to find which APs are on the air, i tried to connect to mine AP - of my router - called "My Lab". Well here start the problems.
Even though i am succesfully connected to my AP (i checked that both on my router's control panel as on the BT5 OS), i wasn't able not only to ping my router in it's default gateway - - but also i couldn't even connect to my router's control panel login page.
I have been seeking for an answer the last 5 days but i wasn't able to find as solution to my problem.
Thus i do please if anyone can help me solve this problem, please give me detailed instructions and guidance because - as i said above - i am new to the BT5 OS and i have a small knowledge generally of the UNIX systems.

Trying to help you understand better - if i can - the status of my BT5 when i connect my wifi-usb adapter i am giving you below the details of specific commands i executed.

root@bt:~# dmesg
[ 1812.392543] cfg80211: Found new beacon on frequency: 2472 MHz (Ch 13) on phy0
[ 1813.475972] wlan0: authenticate with xx:xx:xx:xx:xx:xx (try 1)
[ 1813.483392] wlan0: authenticated
[ 1813.483504] wlan0: associate with xx:xx:xx:xx:xx:xx (try 1)
[ 1813.498764] wlan0: RX AssocResp from xx:xx:xx:xx:xx:xx (capab=0xc21 status=0 aid=1)
[ 1813.498799] wlan0: associated

root@bt:~# ifconfig wlan0
wlan0 Link encap:Ethernet HWaddr yy:yy:yy:yy:yy:yy & nbsp;
inet addr: Bcast: Mask:
inet6 addr: zzzzzzzzzzzzzzzzz/64 Scope:Link
RX packets:27 errors:0 dropped:0 overruns:0 frame:0
TX packets:155 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:3315 (3.3 KB) TX bytes:16780 (16.7 KB)

root@bt:~# iwconfig wlan0
wlan0 IEEE 802.11bg ESSID:"My Lab"
Mode:Managed Frequency:2.427 GHz Access Point: xx:xx:xx:xx:xx:xx
Bit Rate=1 Mb/s Tx-Power=20 dBm
Retry long limit:7 RTS thrff Fragment thrff
Encryption keyff
Power Managementff
Link Quality=70/70 Signal level=-4 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

root@bt:~# ping
PING ( 56(84) bytes of data.
--- ping statistics ---
49 packets transmitted, 0 received, 100% packet loss, time 48000ms

As you can see from the above enen though connected i can not ping my AP.
Please help me

Thank you in advance