Results 1 to 4 of 4

Thread: Realtek RTL8139 probems - How do I "bt nohotplug" from HD boot?

  1. #1
    Junior Member
    Join Date
    Jan 2010

    Default Realtek RTL8139 probems - How do I "bt nohotplug" from HD boot?

    hey dudes, got done installing on dual boot but im having probs with my realtek onbard NIC.. how do I boot with bt nohotplug from the HD? I don't get the "Boot:" menu like it does with the CD?

    I want to try disabling probing on boot as I read on a topic that someone had similar problems with Knoppix, but then manually started the device via modprobe and it got it working.

    I managed to get a sucessfull dhcp IP once out of the 20 odd times ive tried.

    Even when I config a manual IP, it still cant even ping my router.

    ifconfig eth0 detects my card and reveals my MAC... but somthing just stops it from working!!

    I have the driver which is the same version as listed under Linux from the vendor (comes with BT2).

    This is really annoying me.

    Any help much appreacited.

    I have tried other advice from topics.. but not the nohotplug yet because as I mentioned, i dont know how to enter this cmd as BT2 boots up straight away via lilo.

  2. #2
    Junior Member
    Join Date
    Jan 2010


    I think i've narrowed this down to an IRQ conflict.

    I discovered how to make the "appends" in lilo.conf and have been trying various options.

    the main reason why I beleive its down to an IRQ conflict is because before I started trying the append lines, I noticed this from a dmesg output

    8139too Fast Ethernet driver 0.9.28
    PCI: Found IRQ 10 for device 0000:00:10.0
    IRQ routing conflict for 0000:00:07.5, have irq 5, want irq 10
    IRQ routing conflict for 0000:00:07.6, have irq 5, want irq 10
    PCI: Sharing IRQ 10 with 0000:00:0a.1
    eth0: RealTek RTL8139 at 0x1800, 08:00:46:1e:01:65, IRQ 10
    eth0:  Identified 8139 chip type 'RTL-8139C'
      Forcing 10Mbps half-duplex operation.
    eth0: no IPv6 routers present
    NETDEV WATCHDOG: eth0: transmit timed out
    eth0: Transmit timeout, status 0d 0000 c07f media 10.
    eth0: Tx queue start entry 4  dirty entry 0.
    eth0:  Tx descriptor 0 is 0008205a. (queue head)
    eth0:  Tx descriptor 1 is 0008205a.
    eth0:  Tx descriptor 2 is 0008204e.
    eth0:  Tx descriptor 3 is 00082046.
    NETDEV WATCHDOG: eth0: transmit timed out
    Also, I notice on XP that it assigns the NIC with IRQ9 with no problems, however BT always wants to assign it IRQ10.

    Furthermore, the fact that I have managed to have connectivity once or twice out of the many attempts leads me to beleive its an IRQ issue.

    Anyway, I am currently posting this from BT I tried the "pnpbios=on" option (as it is enabled on my bios and windows must be using it)
    however it could just be purely chance like the couple of times before when I had connectivity.

    I Will update when I work on this more to benefit others with similar problems.

    If anyone has any ideas or comments that would be cool.

  3. #3
    Join Date
    Jun 2006



    Do you use lilo for dual booting? if so, you can highlight BackTrack, and then press E, this will stop the counter from counting down. Then you can type the nohotplug statement after the boot:, it will be located down.


  4. #4
    Junior Member
    Join Date
    Jan 2010


    thanks for the info, it looks like I will need to try more troubleshooting.

    well, I booted up again and now im back in the same situation... asolutely no connectivty.

    i config static ip and send pings to my router = "destination host unreachable".

    im growing very tired of this.

    EDIT: I took a look at my current laptop and have decided its time to buy a new one.

    The max ram on this is 256MB... and has an 800mhz CPU...

    Streaming an MP3 and browsing one webpage (when my NIC worked) and my lappy was struggling... its 7 years old.

    So yea, im gonna hunt around and hopefully get a laptop best suited BT2.

    ----------the end------------------

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts