Hi, my problem started when I firstly updated websploit and pentest/metasploit, it started giving me the following error when I tried to launch websploit"Permission denied", I searched and could find no one with same problem, then I tried uninstalling it, and I saw it showed me many errors while trying to uninstall it.. here's an example when I used "sudo dpkg --configure -a" :
sudo dpkg --configure -a
Setting up w3af (1.2-bt2) ...
tar: pybloomfiltermmap-0.2.0.tar.gz: Cannot open: No such file or directory
tar: Error is not recoverable: exiting now
tar: Child returned status 2
tar: Exiting with failure status due to previous errors
/var/lib/dpkg/info/w3af.postinst: line 4: cd: pybloomfiltermmap-0.2.0: No such file or directory
python: can't open file 'setup.py': [Errno 2] No such file or directory

when I tried apt-get install websploit(after uninstalled it, he showed that same error but with this extra lines:
svn: Working copy 'w3af' locked
svn: run 'svn cleanup' to remove locks (type 'svn help cleanup' for details)
dpkg: error processing w3af (--configure):
subprocess installed post-installation script returned error exit status 1
Setting up websploit (2.0.3-bt0) ...
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

Is my library broken? All I did was update my packages..
* Necessary details:

After a description of your problem you need to provide the necessary details so that people will be able to assist you.
By necessary details I refer to:
- Backtrack version GNOME 64bits
- Backtrack installation HDD
- Basic output of commands
lspci - http://pastebin.com/20ui8YHx
lsusb - http://pastebin.com/FTLcWA5c
dmesg - http://pastebin.com/bhu7ah2z