I'm having difficulty with WICD not finding any wireless networks. Ran sudo ifconfig -a ; sudo ifconfig wlan0 up; iwconfig wlan0 essid Eagle1; iwlist wlan0 scan essid Eagle1; and so on. All indications thru terminal window reflected a wireless signal being detected by my laptop, but WICD wasn't finding any wireless. My ssid is not broadcasted, but WICD allows you to 'find a hidden network'. Entering my ssid info, wicd still found nothing.

Reviewing similar threads in other forums i saw that i could purge WICD thru the apt-get purge wicd* ; but when i attempted to do an apt-get install wicd, no luck. Looking at another post, i saw reference to synaptic package mgr. I found the wicd pkg, but of course i couldn't install because--I HAVE NO INTERNET CONNECTION. Yes, it was a bonehead moment.

I restarted my box and ethernet connection found. I used synaptic package mgr to install wicd. Still no wireless.

When i do an IWLIST SCAN i see my router with it's hidden beacon: ESSID: "\x00\x00\x00……"
I then executed SUDO IWCONFIG WLAN0 SCAN ESSID EAGLE1, and i see my ssid and associated parameters: encryption key on, bit rates, freq, etc.
But when i go to the wicd n/w mgr, it tells me there no wireless networks found.

Stumbling upon another forum:
I ran DMESG |GREP WLAN0 and saw the following: ADDRCONF (NETDEV_UP), wlan0: link is not ready.
Then, DMESG |GREP IWL3945, and got this: detected intel wireless wifi link 3945abg.
Then, LSHW -C NETWORK and saw my PRO/Wireless 3945G info, then i ran RFKILL LIST ALL and saw nothing is blocked.

Again, reading some other posts in a different forum I tried several other commands:
cat /etc/network/interfaces (everything ok)
lspci -nn (saw n/w controller info related to Pro/Wireless 3945ABG)
sudo /etc/init.d/networking restart (still no change, wicd reflects "no wireless networks found."
cat /var/log/debug |grep wlan (showed previous dates of when wlan was up, attached, authenticated; the last entries however reflected "disabling the bridge, down, detached.")
cat /var/log/messages |grep wlan (showed multiple lines of "wlan0: link is not ready")

I've tried on my own to resolve, but cant seem to crack this nut; would love some help! I'm using Backtrack 5 (Ubunto 10.04).