Results 1 to 4 of 4

Thread: WICD can't find wireless AP

Hybrid View

  1. #1
    Just burned their ISO
    Join Date
    Jan 2013

    Default WICD can't find wireless AP

    I'm having difficulty with WICD not finding any wireless networks. Ran sudo ifconfig -a ; sudo ifconfig wlan0 up; iwconfig wlan0 essid Eagle1; iwlist wlan0 scan essid Eagle1; and so on. All indications thru terminal window reflected a wireless signal being detected by my laptop, but WICD wasn't finding any wireless. My ssid is not broadcasted, but WICD allows you to 'find a hidden network'. Entering my ssid info, wicd still found nothing.

    Reviewing similar threads in other forums i saw that i could purge WICD thru the apt-get purge wicd* ; but when i attempted to do an apt-get install wicd, no luck. Looking at another post, i saw reference to synaptic package mgr. I found the wicd pkg, but of course i couldn't install because--I HAVE NO INTERNET CONNECTION. Yes, it was a bonehead moment.

    I restarted my box and ethernet connection found. I used synaptic package mgr to install wicd. Still no wireless.

    When i do an IWLIST SCAN i see my router with it's hidden beacon: ESSID: "\x00\x00\x00……"
    I then executed SUDO IWCONFIG WLAN0 SCAN ESSID EAGLE1, and i see my ssid and associated parameters: encryption key on, bit rates, freq, etc.
    But when i go to the wicd n/w mgr, it tells me there no wireless networks found.

    Stumbling upon another forum:
    I ran DMESG |GREP WLAN0 and saw the following: ADDRCONF (NETDEV_UP), wlan0: link is not ready.
    Then, DMESG |GREP IWL3945, and got this: detected intel wireless wifi link 3945abg.
    Then, LSHW -C NETWORK and saw my PRO/Wireless 3945G info, then i ran RFKILL LIST ALL and saw nothing is blocked.

    Again, reading some other posts in a different forum I tried several other commands:
    cat /etc/network/interfaces (everything ok)
    lspci -nn (saw n/w controller info related to Pro/Wireless 3945ABG)
    sudo /etc/init.d/networking restart (still no change, wicd reflects "no wireless networks found."
    cat /var/log/debug |grep wlan (showed previous dates of when wlan was up, attached, authenticated; the last entries however reflected "disabling the bridge, down, detached.")
    cat /var/log/messages |grep wlan (showed multiple lines of "wlan0: link is not ready")

    I've tried on my own to resolve, but cant seem to crack this nut; would love some help! I'm using Backtrack 5 (Ubunto 10.04).

  2. #2
    Administrator sickness's Avatar
    Join Date
    Jan 2010
    Behind the screen.

    Default Re: WICD can't find wireless AP

    Well from what you said everything is working fine except WICD, than do your wireless connectivity more "manually" instead of relying on WICD. I'm sure there are lots of tutorials online on how to do this.
    Back|track giving machine guns to monkeys since 2007 !

    Do not read the Wiki, most your questions will not be answered there !
    Do not take a look at the: Forum Rules !

  3. #3
    Just burned their ISO
    Join Date
    Jan 2013

    Default Re: WICD can't find wireless AP

    Can someone provide some cmds for me to connect manually?

  4. #4
    Just burned their ISO
    Join Date
    Jan 2013

    Default Re: WICD can't find wireless AP

    Can someone provide some cmds for connecting manually a wireless connection?

    Not gettig alot of help thru a variety of forums; I was given this link

    When I run this cmd I get:
    root@bt:~# lsmod |grep iwl3945
    iwl3945 72170 0
    iwl_legacy 65230 1 iwl3945
    mac80211 410313 2 iwl3945,iwl_legacy
    cfg80211 160399 3 iwl3945,iwl_legacy,mac80211

    So I dont see how the above link can help. Would really appreciate some assistance, thanks.

Similar Threads

  1. Can't detect WIRELESS, can't get WICD to work !!!
    By lastHope in forum BackTrack 5 Beginners Section
    Replies: 2
    Last Post: 12-11-2012, 09:17 AM
  2. Wicd not showing any wireless connection
    By Exosphere in forum Beginners Forum
    Replies: 10
    Last Post: 05-07-2011, 08:50 AM
  3. WICD can't find/set IP
    By webpage1111 in forum Beginners Forum
    Replies: 3
    Last Post: 12-08-2010, 06:46 AM
  4. Replies: 3
    Last Post: 06-08-2010, 12:05 PM
  5. wicd can not find access point for wifi
    By bekir in forum Beginners Forum
    Replies: 6
    Last Post: 01-31-2010, 12:40 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts