I've been trying for days to get my Linksys WUSB600N to work with BT4 Final. I could realy use some help.

I have network access using a bridged connection from my wifi connected on my Win7 laptop to VMware. But Nowhere in BT4 can i get it to recognize the device.

I tried to just connect the USB through VMplayer and it works thrugh that but WICD wont show the USB and still wont show anything in BT4.

Here is what im attempting

root@bt:~# iwconfig
lo no wireless extensions.

eth0 no wireless extensions.


airmon-ng start eth0

Found 1 processes that could cause trouble.
If airodump-ng, aireplay-ng or airtun-ng stops working after
a short period of time, you may want to kill (some of) them!

PID Name
7412 dhclient

Interface Chipset Driver

I tried killing the PID and didnt help any.

root@bt:~# airodump-ng eth0
ioctl(SIOCSIWMODE) failed: Operation not supported

ARP linktype is set to 1 (Ethernet) - expected ARPHRD_IEEE80211,
ARPHRD_IEEE80211_FULL or ARPHRD_IEEE80211_PRISM instead. Make
sure RFMON is enabled: run 'airmon-ng start eth0 <#>'
Sysfs injection support was not found either.


root@bt:~# iwconfig eth0 mode monitor
Error for wireless request "Set Mode" (8B06) :
SET failed on device eth0 ; Operation not supported.

I assumed i need a driver, even though they say it works out of the box. I tried this guide RT2870 BT4 Guide (working!!!) - Remote Exploit Forums

But when i type lsusb i get...

root@bt:~# lsusb
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Is this device just not going to work or am i installing the wrong drivers or am i not installing them right?

Please help! I have network access through the bridged(Wired) but it's pointless if i cant enter monitor mode and cant inject.

There has to be something i can do with this USB.