First of all Good Morning everyone.

I have been trying to get Java installed in BT5 R3 for two days. I have searched each of the discussion boards and tried to install via the wiki off of the main page. I have searched google and tried every way the I could find listed.

I am running BT5 R3 in oracle virtualbox
when I run the first command to update alternatives
update-alternatives --install /usr/bin/java java /opt/java/jre1.7.0_05/bin/java 1

I receive the following error
update-alternatives: warning: forcing reinstallation of alternative /usr/lib/jvm/java-6-openjdk/jre/bin/java
beacuse link group java is broken.

updaate-alternatives: warning: not replacing /usr/bin/java with link.

when I run the following command
java --version

I receive
the program 'java' can be found in the following packages:
* gcj-4.4-jre-headless
* openjdk-6-jre-headless
* cacao (you will have to enable component called 'universe')
* gij-4.3 (you will have to enable component called 'universe')
*jamvm (you will have to enable component called 'universe')

All I am trying to do is get java running in firefox.
Any and all assistance would be appreciated.