I run backtrack as a main OS, and recently I wanted to dress it up a bit with Compiz.

Linux bt 3.2.6 #1 SMP Fri Feb 17 10:34:20 EST 2012 x86_64 GNU/Linux

I have followed all directions on the tutorial here: http://www.backtrack-linux.org/forum...ad.php?t=29035 the only thing I wasn't able to grab was ' compiz-fusion-plugins-unsupported ' but everything installed fine, in my rc.local file I added everything just like the tutorial but left out the compiz-fusion-plugins-unsupported package. What happens is when I reboot everything loads fine with no errors before prompting root log in. After I startx everything loads fine, but the blue icon for the Compiz Fusion isn't in my upper bar, and my settings which are woggle windows do not work.. When I manually load Compiz Fusion Icons it loads fine > right click I have tried each option differently with no success. The screen flickers and nothing happens..

When I type just 'compiz' in my terminal this is what happens

Unrecognized deviceID 126
compiz (core) - Fatal: No valid GL extensions string found.
compiz (core) - Error: Failed to manage screen: 0
compiz (core) - Fatal: No manageable screens found on display :0.0

Launching fallback window manager

I have been googling the issue for a day now and suspect its something to do with my intel card..

lshw -c video
       description: VGA compatible controller
       product: 2nd Generation Core Processor Family Integrated Graphics Controller
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 09
       width: 64 bits
       clock: 33MHz
       capabilities: msi pm bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:50 memory:dd000000-dd3fffff memory:c0000000-cfffffff ioport:e000(size=64)
The computer I have is a Asus laptop, I have tried to get compiz to play nicely with my intel i915 card, because this has worked before on bt5 32bit for me

apt-get purge nvidia-*
apt-get install --reinstall xserver-xorg-video-intel libgl1-mesa-glx libgl1-mesa-dri xserver-xorg-core
dpkg-reconfigure xserver-xorg
update-alternatives --remove gl_conf /usr/lib/nvidia-current/ld.so.conf
I have also followed another tutorial on here when I first installed to load my i915 driver here: http://www.backtrack-linux.org/forum...ad.php?t=48904 , not sure if this is of any help I have got this to work before on another install of bt5 32bit.

Any advice or a pointer in the right direction would be much appreciated

Thank you