Hi guys , so few weeks ago a friend told me about backtrack. Instantly the same day i downloaded the BT5R3. I run the backtrack with VMWare (as a virtual machine). Everything was ok except for one but hell of a big problem, when i get in shell and write the following:
root@bt:~# airmon-ng

Interface	Chipset		Driver

wlan0		Ralink RT2870/3070	rt2800usb - [phy0]
so far so good ... next step:
root@bt:~# airmon-ng start wlan0

Found 2 processes that could cause trouble.
If airodump-ng, aireplay-ng or airtun-ng stops working after
a short period of time, you may want to kill (some of) them!

PID	Name
1079	dhclient3
1778	dhclient3
Process with PID 1778 (dhclient3) is running on interface wlan0

Interface	Chipset		Driver

wlan0		Ralink RT2870/3070	rt2800usb - [phy0]
				(monitor mode enabled on mon0)
root@bt:~# airodump-ng mon0

 CH  9 ][ Elapsed: 40 s ][ 2013-01-20 11:32                                    
 BSSID              PWR  Beacons    #Data, #/s  CH  MB   ENC  CIPHER AUTH ESSID
 BSSID              STATION            PWR   Rate    Lost    Frames  Probe
.... after even 10 minutes all the same. Really annoyng problem .
This problem was with backtrack 5 r3. When i installed and ran B5R1 the airodump-ng command dumped all the networks and worked fine, even cracked one password, but after 3 or 4 logs in r1 same crappy problem.

The main problem is how to enable or force or something the airodump-ng to make the external usb drive to show all available networks!

Please help me guys, what should i do. I really want to work with backtrack!!!