Hey guys,

So, I have installed backtrack 5 r3 on a Virtual box and often use it for playing about with wifi exploits on my home network. Both myself and my housemate have it on our home PC's and laptops too.

I have an Atheros wifi usb card and the wifi guides all over the internet are all good. Airmon, Airodump, Aireply and Aircrack all work and I have no issues with backtrack5 in this respect.

However, I am now expanding my knowledge to network connected exploits and cisco switches. However, I cannot get any of the metasploit or armatage functions of bt5 to work correctly.

I am not sure if this is a setting with the network on my actual VB setup, as the wireless manager option no longer appears within backtrack since setting to a bridged connection :/

To add any extra advice see below:

I have found guides on changes between r2 and r3 and have tried a fresh install of metasploit using the commands 'apt-get update', which crashed (found the advice here: http://www.backtrack-linux.org/backt...acktrack-5-r3/, however it doesnt say about errors or if it crashes), followed by the command 'svn cleanup' and trying to get the update to run again.

On a side note, I have tried following guides, one here (https://community.rapid7.com/communi...metasploit-pro) seemed to work, but I could not register metasploit, the site doesnt seem to want to load on my virtualbox.

I also cannot get the DHCP3-Server settings to work, it simply hangs on the pop up window with the bar ticking up. I assume this is a Java / Flash update issue?

Any help would be greatly appreciated.

I have tried to use the search functions here, but cannot find a suitable answer. If I am just being an idiot, please just feel free to point and laugh and point me to a newbies guide to setting stuff like this up :P

Thanks in advance,