Results 1 to 4 of 4

Thread: Problem with startx and with the boot loader...

  1. #1
    Just burned his ISO
    Join Date
    Oct 2007

    Default Problem with startx and with the boot loader...

    Hi all.
    As you can see I have 2 problems.
    Yesterday i tried the liveCD of BT2 on my laptop and everything went fine, boot on the cd, run startx and the GUI apears.
    Then i decided to install it on my laptop.
    It was already with a double boot XP (sda1) - Ubuntu (sda2).
    As i didnt find any partition editor in BT2 (if there is really none than it is a miss) i decided to overwright the ubuntu partition.

    Install finishes, i reboot...
    So first of all i lost the boot loader, and BT2 loads alone, i cant get to XP.
    then comes the startx part. I log in, run startx and get an error ending with this "XIO : fatal IO error 104"

    i ll try to copy you some :

    dlopen: /lib/tls/ version 'GLIBC_2.4' not found (required by /usr/lib/
    EE Failed to load /usr/lib/xorg/modules/extensions//
    EE Failed to load module "dri" (loader failed,7)
    EE Screen(s) found, but non have a usable configuration

    If you need more i ll type it.

    The laptop is a Fujitsu Siemens AMILO, and i never get any real problem with other linux distros.

    I guess if we solve the display problem we will be abble to solve the boot loading problem too.
    I gave a look in /boot/grub menu.lst and i still see there all the entries for Ubuntu or XP ...

    I guess you will need to know some more details so i stay around ...


  2. #2
    Senior Member shamanvirtuel's Avatar
    Join Date
    Mar 2010
    Somewhere in the "Ex" human right country



    all of these are partition softwares......include in bt.... qtparted is a gui !

    you really don't search.....

    and the correct procedure is not to use grub, but overwrite it with bt lilo and edit lilo to reflect your other systems.......

    for startx .....

    type this
    xconf && startx
    Watch your back, your packetz will belong to me soon... xD

    BackTrack :
    Giving Machine Guns to Monkeys since 2006

  3. #3
    Just burned his ISO
    Join Date
    Oct 2007


    xconf && startx ...
    I did it and it gives the same result when startx fails....

    I already tried xconf and it seemt to work .....
    "all done. Run startx now. If you get black screen, hit ctrl+alt+Plus".....
    But startx refuses to get working. btw i also tried flux and i got the same problem......

    I cant understand why the LiveCD had no problem with startx and the clean install does.

  4. #4
    Just burned his ISO
    Join Date
    Oct 2007


    well i "solved" the boot part following a HOW to

    not really solved because I can now boot on XP without problem, but when i ask lilo to boot on BT, it starts but stays locked on a black screen, and there is no way to get out of it, not even keeping the power button... had to remove the laptop battery

    i ll keep trying ...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts