Okay so this is my first forum post, please bear with me.


Pretty much brand new desktop PC running Windows 7

Edimax 11N USB wireless LAN utility (EW-7717Un)

BT5 R3 boot from a USB pen, although perhaps worth mentioning it will only work if I choose the no DRM option.

On typing iwconfig, wlan0 does show up, but all the values provided are 'off', 'no' or '0'. The BT5 wireless manager is picking up nearby networks, however, leading me to believe this isn't a driver issue.

Airmon-ng start wlan0 - nothing happens, it says 'interface, chipset' etc but no details below it.

On typing airodump-ng wlan0 I get 'ARP Linktype set to 1, expected ARP<numbers>' .... 'ensure RFMON is enabled' ...

I also tried airodump-ng mon0 - no such device.

I acquired the BSSID of said network and tried pointing reaver to it with the command

'reaver -i wlan0 -b xx:xx:xx:xx:xx:xx'

Response was 'waiting for beacon from <bssid>' but nothing happens after this.

I also tried 'sudo iwconfig wlan0 mode monitor' and got:

'SET failed on device wlan0; invalid argument'.

The signal strength of the required network is about 80%, and also worth mentioning I don't have an Internet connection at the moment, so any sys files or updates I need are being brought on 2nd USB pen/copied to the C drive so I can use the '1TB file system' to access it if required, although that hasn't proved much use.

It's doing my head in. I just want to get on this network.

Any help much appreciated,