Results 1 to 2 of 2

Thread: WIFI working then seems to halt again

  1. #1
    Just burned their ISO
    Join Date
    Dec 2012

    Default WIFI working then seems to halt again

    I am trying to pentest my WPS vulnerable wireless lan using BT5 r3 / Reaver running in VirtualBox 4.2.6 r82870 with a USB wireless dongle

    Opening Wicd Network Manager in BT the dongle flashes away happily and I can see my network with good signal strength (90%).

    I get:
    lo        no wireless extensions.
    wlan0     IEEE 802.11bgn  ESSID:off/any  
              Mode:Managed  Access Point: Not-Associated   Tx-Power=20 dBm   
              Retry  long limit:7   RTS thr:off   Fragment thr:off
              Encryption key:off
              Power Management:on
    eth0      no wireless extensions.
    It's in managed mode so I issue the following to get it into monitor mode:
    ifconfig wlan0 down
    iwconfig wlan0 mode monitor
    ifconfig wlan0 up
    iwconfig wlan0
    wlan0     IEEE 802.11bgn  Mode:Monitor  Tx-Power=20 dBm   
                  Retry  long limit:7   RTS thr:off   Fragment thr:off
                  Power Management:on

    Issuing command :
    airmon-ng start wlan0
    If airodump-ng, aireplay-ng or airtun-ng stops working after
         a short period of time, you may want to kill (some of) them!
         PID     Name
         571     dhclient3
         1760     dhclient3
         Process with PID 1760 (dhclient3) is running on interface wlan0
         Interface     Chipset          Driver
         wlan0          Ralink RT2870/3070     rt2800usb - [phy1]
                             (monitor mode enabled on mon0)
    I kill the above processes (although tried also without killing them):
    killall -9 dhclient
    The problem I am experiencing occurs with:
    airodump-ng wlan0
    No networks show up even though I know they are there when confirmed previously with Wicd Manager before issuing above commands. The dongle does not show any light activity at this point and going into Wicd shows "No wireless networks found".

    It's as if the dongle has stopped working all of a sudden.

    I never had the problem when running BT from the live CD and was able to get a list of Wireless networks in airodump-ng without problem.

    What am I doing wrong?

  2. #2
    Very good friend of the forum maverik35's Avatar
    Join Date
    Sep 2009
    Debian land

    Default Re: WIFI working then seems to halt again

    first, I have never seen the "down" or "up" parameter in iwconfig...It must be brought up/down using ifconfig (ifconfig wlan0 down or up).
    Second, you might not have to kill those proccesses, ...The message is caused because the interface has been set in monitor mode, dhclient is a protocol to connect to an AP and to connect to an AP, interface must be set in managed mode, that is why..being in monitor mode and running dhclient might not affect operation.

    I have done it before with my alfa 500 and it runs like a charm even with the message. Read carefully, I use the term "might" and not "will"..Try it as it worked for me with or without killing the dhclient.

    Try it again, but issuing the ifconfig command....

Similar Threads

  1. Backtrack 5 Wifi not working
    By alpiccio in forum BackTrack 5 Beginners Section
    Replies: 0
    Last Post: 11-27-2012, 11:58 AM
  2. Can't poweroff/halt
    By n3tb4ng3r in forum BackTrack 5 Bugs
    Replies: 1
    Last Post: 03-25-2012, 12:08 AM
  3. USB Wifi not working
    By soto3330 in forum Beginners Forum
    Replies: 6
    Last Post: 06-20-2010, 07:18 AM
  4. Replies: 5
    Last Post: 11-23-2009, 04:55 AM
  5. Not sure if my WiFi is working...
    By Sunnz in forum OLD Newbie Area
    Replies: 4
    Last Post: 11-27-2008, 06:05 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts