Results 1 to 5 of 5

Thread: PAE Issue

  1. #1
    Just burned his ISO
    Join Date
    Jul 2010

    Default PAE Issue


    I need to install Nexpose community edition in BT5 R3.
    Presently using BT5 R3 in vmware workstation9. Assigned 6 GB of Ram to VM Machine but 32 bit of BT5 Gnome only shows up around 3GB Ram.

    To overcome this followed the linked
    and checked cat/proc/meminfo and it only shows around 3GB of RAM stilll.So is Nexpose gives the error of less memory.

    I can check under /usr/src/linux# make menuconfig maximum memory being set afteer reboot is 64GB.

    Is there any possibilty if this can be resolved or something I am missing?


  2. #2
    Very good friend of the forum maverik35's Avatar
    Join Date
    Sep 2009
    Debian land

    Default Re: PAE Issue

    PAE means Physical Address Extension..If you have a 32-bit OS in linux, you have this option, to install a PAE kernel to address more than the 32-bit OS memory boundary (3Gb)...In 64bit arquitecture, you do not have that problem...So if you have a 32bit processor and want to address more than 3Gb boundary, yes you need a kernel to do so.

    If you have a 64Bit processor, use a 64bit distro and solve the memory boudary issue.

    There are other Kernels who will do the same thing, but in BT5 the PAE is the one used according to wiki...

  3. #3
    Just burned their ISO
    Join Date
    Jan 2013
    In a chair

    Default Re: PAE Issue

    I just got it to boot to the new kernel finally. The guide we were following is missing a couple of important steps:

    cp /usr/src/linux-source-`uname -r`/arch/x86/boot/bzImage /boot/vmlinuz-`uname -r`-hmem
    cp /usr/src/linux-source-`uname -r`/ /boot/

    (These steps copy the modified kernel in the the /boot directory where they can be picked up by the update-grub2 command)

    I got those steps from the BT4 PAE guide:

    Now I have a new problem:
    ALL usb devices are missing
    ALL network devices are missing

    I am seeing an error like this "/sbin/modprobe -bv pci:'<followed by some numbers>' unexpected exit with status 0x000b"

    but I can see that the 8GB is finally being used! I am so close. This is killing me. Once I get the memory working the system is now 100% useless. Luckily I can still boot in to the older kernel and try again but I'm not sure how to fix this kernel...

    Have you ever seen a kernel get borked like this?

  4. #4
    Just burned their ISO
    Join Date
    Jan 2013

    Default Re: PAE Issue

    Certainly. I agree with you.

  5. #5
    Just burned their ISO
    Join Date
    Feb 2013

    Default Riferimento: PAE Issue

    i I solved this way
    this worked for me .NB system installed on the machine and not in live cd not vm (of course)

    root@bt:~# prepare-kernel-sources
    andare nella directory del kernel nel mio caso 3.2.6
    go to the directory of the kernel in my case 3.2.6
    root@bt:~# cd /usr/src/linux-source-3.2.6
    Bacup .config
    root@bt:/usr/src/linux-source-3.2.6# zcat /proc/config.gz > .config
    avviare il menu di configurazione

    root@bt:/usr/src/linux-source-3.2.6#make menuconfig
    Cercare la voce
    Search for item
    Processor type and features ---> (select)
    cercare la voce
    Search for item
    High Memory Support (4GB) ---> (select)
    marcare la voce
    mark the entry
    (X) 64GB
    salvare ed uscire
    save and exit
    root@bt:/usr/src/linux-source-3.2.6# make
    (il processo dura un'ora circa process takes about an hour)
    root@bt:/usr/src/linux-source-3.2.6# make modules
    root@bt:/usr/src/linux-source-3.2.6# make modules_install
    root@bt:/usr/src/linux-source-3.2.6#make scripts
    root@bt:/usr/src/linux-source-3.2.6#make prepare
    copiare bzImage in vmlinuz-3.2.6
    copy bzImage in vmlinuz-3.2.6
    root@bt:/usr/src/linux-source-3.2.6# cp /usr/src/linux-source-3.2.6/arch/x86/boot/bzImage /boot/vmlinuz-3.2.6
    copiare in
    copy in
    11. root@bt:/usr/src/linux-source-3.2.6# cp /usr/src/linux-source-3.2.6/ /boot/
    creare un collegamento simbolico della cartella linux in build
    create a symbolic link to the folder in linux build
    root@bt:/usr/src/linux-source-3.2.6#ln -s /usr/src/linux /lib/modules/3.2.6/build
    creare la nuova immagine initramfs
    create a new initramfs image
    mkinitramfs -o /boot/initrd.img-3.2.6 3.2.6
    aggiornare l'immagine
    update the image
    root@bt:/usr/src/linux-source-3.2.6# update-initramfs -u
    aggiornare grub
    update grub
    root@bt:/usr/src/linux-source-3.2.6# update-grub
    root@bt:/usr/src/linux-source-3.2.6# reboot
    spero di averti aiutato e di aiutare tutti quelli che hanno lo stesso problema
    I hope I helped and to help all those who have the same problem
    I hope that English is good because I have translated from the internet

Similar Threads

  1. Replies: 2
    Last Post: 12-25-2011, 09:56 PM
  2. Airodump-ng Issue + Aireplay-ng Issue
    By whiteice in forum OLD Newbie Area
    Replies: 1
    Last Post: 11-05-2008, 05:47 AM
  3. c++ issue
    By dementia_reign in forum OLD Programming
    Replies: 6
    Last Post: 05-22-2008, 12:11 PM
  4. Issue with EEE PC 4G!!
    By crashreb0ot in forum OLD BT3beta General
    Replies: 5
    Last Post: 02-15-2008, 05:20 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts