Results 1 to 2 of 2

Thread: WICD Adventure

  1. #1
    Just burned their ISO
    Join Date
    Dec 2012

    Default WICD Adventure

    Running BT5R3 amd64. Ran update/upgrade...wicd wouldn't work so I looked and looked and looked, but the solutions didn't seem to work in my case. I reinstalled and ran into more wicd issues such as it disappearing entirely. So, here is what worked for me. I hope maybe it will help someone down the road.

    I had to install several packages. This was a challenge since I was trying to connect via usb tether as it was my only choice at the time and location. What I did was download the packages from Windows 7 since that is my primary OS. I then rebooted in BT and moved the files over. I think this took about 10 reboots in the end, but I got there. Here are the packages and order I installed them:

    dhcpcd-dbus_0.5.2-2_amd64.deb #this ended up not being needed
    dhcpcd5_5.2.12-1_amd64.deb #this might not be needed. I have not removed it, but after installing it I still had no working wicd.
    dhcpcd_3.2.3-9ubuntu0.1_amd64.deb #i think this was what I really needed as opposed to the previous 2 ^^^
    wicd-kde_0.2.1-5_amd64.deb #after this and reboot I now had working wicd and also an icon in the systray which was not my goal, but a nice bonus

    After this I went into wicd and connected via usb0. I got an IP address, but my internet connection still wouldn't work. After glancing at more topics I did 2 things:

    in /etc/network/interfaces I added "auto usb0 iface usb0 inet dhcp" #I don't think I needed this

    in /etc/resolv.conf I added a line "nameserver 192.168.x.x" #the IP I used was the gateway listed after running the "route" command.
    #after this I tried again and had a successful connection.

    I hope someone out there finds this helpful!

  2. #2
    Very good friend of the forum maverik35's Avatar
    Join Date
    Sep 2009
    Debian land

    Default Re: WICD Adventure

    Well, you could have installed wicd from repos: aptitude install wicd, it will also install all wicd dependencies..It is highly recommended to ask before installing something, it could have saved you a lot of work and problems.

    As to having the connection to work, eliminate the "auto usb0 iface usb0 inet dhcp"..You do not need to do it in wireless or usb since you have a plugin daemon which will detect conection of device..It can cause you some problems...Need to read more about network-manager...

    As to resolv.conf, this file will always be overwritten by any of this 3 things:
    1. Networking Manager
    2. Resolv app
    3. dhclient

    So you need to go to /etc/dhcp3/ and edit dhclient.conf, at the line commented: #prepend domain-name-servers, uncomment it and add your dns, I use the (Google's) and the gateway 192.168.x.x Then just save it and reboot...

    You might want to read about dhclient.conf too...

    Last edited by maverik35; 12-12-2012 at 01:32 PM.

Similar Threads

  1. help with Wicd in BT4-R2, please...
    By 911nimo in forum Beginners Forum
    Replies: 0
    Last Post: 03-23-2011, 09:51 AM
  2. Possible WICD bug?
    By orgcandman in forum Beginners Forum
    Replies: 4
    Last Post: 01-09-2011, 02:56 PM
  3. wicd won't appear at all.
    By ienaxxx in forum OLD Newbie Area
    Replies: 5
    Last Post: 11-27-2009, 08:27 PM
  4. Wicd
    By vladi in forum OLD BackTrack 4 Package and feature Requests
    Replies: 2
    Last Post: 07-25-2009, 09:13 AM
  5. Anyone ever use WICD in BT3 or even BT2?
    By ravalox in forum OLD BT3beta General
    Replies: 11
    Last Post: 12-05-2008, 01:41 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts