Hello All,

After installing BT2 to my HDD I ran into a little annoyance regarding DHCP and my default route/Gateway.

Intermitendly I was losing my default gateway and having to issue the ROUTE command to reset the GW setting manually. Also when I ran the network script /etc/rc.d/rc.inet1 it did not seem to fix the problem. I needed to reboot the whole machine = frustration!

What I found is that for some reason DHCP was not cleaning up after itself. It was being silly and not requesting new information if the lease had not expired.

The solution I found was to add the following line to the very beginning of the /etc/rc.d/rc.inet1 script.

rm -f /etc/dhcp/dhcpd*

If you want to do this for a specific interface, IE not your wlan or something, you can tweak it.

For example my wired interface is eth0 and my wifi is eth1. So to have my lan line PID and cache info file removed and not my wifi I change the line to this

rm -f /etc/dhcp/dhcpd-eth0*

This may be a sloppy way to fix this, but I wanted to share what I had learned. If anyone knows of a less "hack and slash" method please let me know.