I installed BT5 in 64-bit Samsung laptop (along with Win7 in other partition).
However, after completing the installation, the very first time I tried using wicd, I got

could not connect to wicd's d-bus interface
Next I tried these and restarted my laptop,
# dpkg-reconfigure wicd
# update-rc.d wicd defaults
After restarting, the error did not appear. However, wicd showed me the message "No Wireless networks found".
No matter, what I do (refreshing, restarting) it remains same.

I also tried checking a few more things. Assuming that those info may be useful for you guys to help me out, I am posting those below:

# lspci -v | grep -i "Network"
01:00.0 Network controller: Intel Corporation Device 088e (rev 24)

# iwconfig
lo  no wireless extensions.

IEEE 802.11abgn ESSID:off/any
Mode: Managed Access Point: Not-Associated  Tx-Power= 0 dBm
Retry long limit: 7 RTS: Off Fragment thr: off
Encryption Key: off
Power Management:off

no wireless extensions.

# ethtool -i wlan0
driver: iwlwifi
version: 3.2.6
firmware-version: build 33993
bus-info: 0000:01:00.0

Thanks guys