Results 1 to 6 of 6

Thread: CUDA 5.0 & Pyrit - Nearly there

Threaded View

  1. #1
    Junior Member
    Join Date
    Feb 2012
    over here!

    Default CUDA 5.0 & Pyrit - Nearly there

    Hi All,

    Anyone had any luck getting CUDA + Pyrit working on a GTX 670 under BT5R3?

    I recently upgraded my GPU from a GTX 260 and thought I would try and follow my old post about how I got that working:

    No dice! I get weird artifacts all over the screen and keep hitting about 28,000 PMK/s before it crashes after about 20 seconds. (I am not even logging into xserver to run the test).

    It gives the following error (please excuse my typing - I am copying from a photo!)


    [18700.122794] NVRM Xid (0000:01:00): 13, 0001 00000000 0000a0c0 000002bc 00000003 00000000
    Exception in thread CUDA-Device #1 'Geforce GTX 670':
    Traceback (most recent call last):
    File "/usr/lib/python2.6/", line 532, in _bootstrap_inner
    File "/usr/local/lib/python2.6/dist-packages/cpyrit/", line 116, in run res = self.solve(esid, pwlist0

    Exception in thread CPU-Core (SSE2):
    Traceback (most recent call last):
    File "/usr/lib/python2.6/", line 532, in _bootstrap_inner
    File "/usr/local/lib/python2.6/dist-packages/cpyrit/", line 110, in run essid, pwlist = self.queue.gather(self.buffersize, timeout=0.5)
    File "/usr/local/lib/python2.6/dist-packages/cpyrit/", line 632, in _gather self._check_cores()
    File "/usr/local/lib/python2.6/dit-packages/cpyrit/", line 490, in _check_cores raise SystemError("The core '%s' has died unexpectedly" % core)
    SystemError: the core 'CUDA-Device #1 'Geforce GTX 670'' has died unexpectedly

    Traceback (most recent call last):
    File "/usr/local/bin/pyrit", line 6, in <module>
    File "/usr/local/lib/python2.6/dist-packages/", line 117, in initFromArgv func(self, **options)
    File "/usr/local/lib/python2.6/dist-packages/", line 1213, in benchmark for r in cp:
    File "/usr/local/lib/python2.6/dist-packages/cpyrit/", line 507, in _iter_ r = self.dequeue(block=True)
    File "/usr/local/lib/python2.6/dist-packages/cpyrit/", line591, in dequeue self._check_cores()
    File "/usr/local/lib/pyhton2.6/dist-packages/cpyrit/", line 490, in _check_cores raise SystemError: The core 'CUDA-Device #1 'GEFORCE gtx 670'' has died unexpectedly


    I am no coder, and the original guide I wrote was a hotch-potch of other people's work. I am out of my depth with this error.

    I am using the production release of CUDA (5.0.35) for Ubuntu 10.04 from the NVIDIA website. I have tried with the graphic driver bundled with CUDA 5.0.35 as well as the latest driver from NVIDIA (310.19). I am using the latest version of pyrit (0.4.1-dev (svn 308)) and have made sure that I am running pure Ubuntu 10.04 by blocking dist upgrades in kpackagekit.

    I have tried the Backtrack wiki solution:

    but the CUDA 4 drivers do not appear to be compatible with the GTX 670 and won't install.

    I have tried both 64 and 32 bit versions/re-installs to no avail. I have also tried installing CUDA to default directories as well as /opt/

    Any help greatly appreciated.

    EDIT: I should add this in NOT a Sandy Bridge and there is no onboard graphics to confuse things. Its on a Phenom II.

    I noticed that on attempting again, it could be an issue with building cuda for pyrit ie..

    running build
    running build_ext
    Skipping rebuild of Nvidia CUDA kernel
    Building modules....

    Going to try it in Maya and see if it works...
    Last edited by twocents; 12-07-2012 at 06:51 PM. Reason: update

Similar Threads

  1. need some help with cuda and pyrit
    By intertan in forum Beginners Forum
    Replies: 3
    Last Post: 02-16-2011, 05:45 PM
  2. help with pyrit and cuda
    By samthedeer in forum Beginners Forum
    Replies: 2
    Last Post: 09-10-2010, 03:37 AM
  3. pyrit with CUDA support not showing CUDA cores
    By kill_box001 in forum Beginners Forum
    Replies: 7
    Last Post: 08-14-2010, 06:29 PM
  4. Pyrit error cuda
    By jeppoo in forum OLD BackTrack 4 (pre) Final
    Replies: 1
    Last Post: 01-29-2010, 12:49 AM
  5. pyrit .2.4 - 0.2.5 not working with cuda?
    By andytof47 in forum OLD BackTrack 4 General Support
    Replies: 9
    Last Post: 01-22-2010, 01:55 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts