Hello all,

I have spent many hours so far pouring over the web trying to solve this issue.

I have a Asus Eee PC 1011CX
2gb Ram
Intel N2600 1.6ghz dual core
Intel GMA3600 video chip set

I downloaded and installed BT5R3 GNOME 32 bit and installed to a USB drive with unetbootin
When it boots up it comes up undefined video mode 317 and it gives me the option to pick a new resolution by hitting enter. When i do i can pick the option 9 for 800x600x32 VESA
When i do this it boots up fine from the usb and works great. I ran the install and did a full clean install to the hard drive. This also went without any errors.
However, when i reboot i no longer get the option to pick the video resolution. it will go to the Ubuntu 10.04 screen with the 4 dots, then very quickly (to fast to see) red text will flash in the middle of the screen and it goes blank.

The back light is fine, there's no courser just a blank screen.

Now since i can get it work off the usb by picking the right video mode i really just need to know how to get the hard drive install to either allow me to do that or to hard code it.

So far I've changed the grub with this
ran update-grub after mounting with this
# Mount root partition:
sudo mount /dev/sdXY /mnt # /dev/sdXY is your root partition, e.g. /dev/sda1
# If you have a separate boot partition you'll need to mount it also:
sudo mount /dev/sdYY /mnt/boot
# Mount your virtual filesystems:
for i in /dev /dev/pts /proc /sys /run; do sudo mount -B $i /mnt$i; done
# Chroot
sudo chroot /mnt

didnt work

i tried
GRUB_CMDLINE_LINUX_DEFAULT="text splash nomodeset vga=791"
and the Intel i915 one
neither worked either

long story short it works fine when i can pick that 800x600x32 setting so i need to fig out what the boot option is setting from the USB stick and hard code that or change it on the hard drive install

Any and all help would be much appreciated.