I am trying to install Backtrack 5r3 on my Gigabyte s1081
i have already followed the instructions from the other forum and here is my progress

Initially the booting caused "Ubuntu 10.04" to display then it freezes
I edited the Grub file and now boot is ok.the vga=0x315 solution works
Intalled rungetty for auto log in (yup,i have an idea on the dangers or running root but i want to test if the installation is possible)
Now backtrack boot is ok

Installed virtual keyboard (gigabyte has a touch button that acts like a mouse.that works ok)
When i connect to a wifi broadband dongle,internet is ok
But when i connect to home wifi,initially it freezes then restarts
Then i get a bad password error.i have searched for answers in the forum and i tried the WICD solution.but unfortunately it did not i get an error that i have no wifi network

Also i wanted to make the touchscreen to work.i have the driver cd for the tablet and i tried to install it.
Wine does not install it so i edit the wine config (something about removing the cautious mode of wine)
But still when i tried it,it says something about the permission.i tried chmod and it says to install Mono
Since i have no internet,i cannot download it.also i am not sure if there is a downloadable driver for the touchscreen

Hopefully someone can help me.gigabyte looks like a promising pentest tool because of the available ports
Jasseger will also work because of the lan port.

I tried looking but all i got is an android how to.

I also wanted to dual boot,i made a mistake in converting to dynamic disk (yeah,i know)
Dont try the edit by hex approach,my windows 7 not to convert to dynamic